Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using ubuntu 11.10 for a couple of months.

but Today after restart my laptop I can't get wireless on. I tried to install windows wireless drivers but it didn't work too.

and It's not off by rfkill too.

# rfkill list all
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: dell-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no

when I tried

# ifconfig wlan0 up
wlan0: ERROR while getting interface flags: No such device
and
# lshw -C network  *-network
description: Ethernet interface product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller vendor: Realtek Semiconductor Co., Ltd. physical id: 0 bus info: pci@0000:05:00.0 logical name: eth0 version: 05 serial: 78:2b:cb:e6:7a:ca size: 10Mbit/s capacity: 100Mbit/s width: 64 bits clock: 33MHz capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8105e-1.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s resources: irq:46 ioport:d000(size=256) memory:f3204000-f3204fff memory:f3200000-f3203fff *-network UNCLAIMED description: Network controller product: Centrino Wireless-N 1030 vendor: Intel Corporation physical id: 0 bus info: pci@0000:09:00.0 version: 34 width: 64 bits clock: 33MHz capabilities: pm msi pciexpress cap_list configuration: latency=0 resources: memory:f7a00000-f7a01fff *-network description: Ethernet interface physical id: 2 logical name: eth2 serial: 00:1f:1f:96:af:41 capabilities: ethernet physical configuration: broadcast=yes driver=cdc_ether driverversion=22-Aug-2005 firmware=CDC Ethernet Device ip=192.168.2.3 link=yes multicast=yes

Now where is the problem and How should I solve it?

share|improve this question
    
is your hardware switch on? askubuntu.com/q/44863/10698 –  Alvar May 22 '12 at 8:21
    
yes,and It works correctly in Windows –  Moein7tl May 22 '12 at 8:33

1 Answer 1

This might help you. Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

sudo apt-get install linux-backports-modules-wireless-oneiric-generic
sudo reboot
share|improve this answer
    
For Ubuntu precise this would be installing linux-backports-modules-cw-x.y-precise-generic (where x.y is e.g. 3.6) to get backported wireless modules for the regular Ubuntu kernel. –  gertvdijk Dec 31 '12 at 0:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.