Alright, so I was messing around with libssl and I manged to mess up libssl pretty well. It looks like I installed a separate version of libssl 64 than I've for libssl32 and now I can't use
apt-get at all.
sudo apt-get install -f:
$ sudo apt-get install -f Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following package was automatically installed and is no longer required: libssl1.0.0:i386 Use 'apt-get autoremove' to remove them. The following extra packages will be installed: libssl1.0.0:i386 The following packages will be upgraded: libssl1.0.0:i386 1 upgraded, 0 newly installed, 0 to remove and 7 not upgraded. 4 not fully installed or removed. Need to get 0 B/1,004 kB of archives. After this operation, 23.6 kB of additional disk space will be used. Do you want to continue [Y/n]? y E: Internal Error, No file name for libssl1.0.0
sudo apt-get upgrade:
$ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: libssl1.0.0 : Breaks: libssl1.0.0:i386 (!= 1.0.1-4ubuntu5) but 1.0.0e-2ubuntu4.5 is installed libssl1.0.0:i386 : Breaks: libssl1.0.0 (!= 1.0.0e-2ubuntu4.5) but 1.0.1-4ubuntu5 is installed E: Unmet dependencies. Try using -f
sudo dpkg --configure -a:
$ sudo dpkg --configure -a dpkg: error processing libssl1.0.0 (--configure): libssl1.0.0:amd64 1.0.1-4ubuntu5 cannot be configured because libssl1.0.0:i386 is in a different version (1.0.0e-2ubuntu4.5) dpkg: error processing libssl1.0.0:i386 (--configure): libssl1.0.0:i386 1.0.0e-2ubuntu4.5 cannot be configured because libssl1.0.0:amd64 is in a different version (1.0.1-4ubuntu5) dpkg: dependency problems prevent configuration of openssl: openssl depends on libssl1.0.0 (>= 1.0.1); however: Package libssl1.0.0 is not configured yet. dpkg: error processing openssl (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of libssl-dev: libssl-dev depends on libssl1.0.0 (= 1.0.1-4ubuntu5); however: Package libssl1.0.0 is not configured yet. dpkg: error processing libssl-dev (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: libssl1.0.0 libssl1.0.0:i386 openssl libssl-dev
Any help would be appreciated!