Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been using Virtualbox with Ubuntu for a few years now, and I've noticed a change in behavior of keyboard shortcuts sometime recently, possibly after a new version update: in the past, when the guest had the keyboard focus, I was unable to use most of the host's keyboard shortcuts, such as switching virtual desktops; I had to either click on the host desktop, if I could, or, I later found, I could use AWN (in the auto-hide mode) to make use of its desktop switcher applet.

However... now I can no longer get the guest keyboard shortcuts to work at all. None of them will work any longer, even with the same VMs I've always used.

I haven't found any settings for this, which would be ideal, as I can see some situations where this would be a feature, but overall, I'd like them to work like they did previously, where I was able to do things like switch virtual desktops or run a terminal with a hotkey.

share|improve this question
    
Sorry, in the first paragraph you are talking about the host keyboard shortcuts requiring extra focus methods to work (I also have noticed that I can't just hit the host key and use some keyboard shortcuts), but then in the second paragraph you are talking about guest keyboard shortcuts no longer working. Is this a typo or am I just not catching something? Could you give an example of some specific things that you now cannot do? –  adempewolff May 22 '12 at 2:53
    
No, not a typo, but I guess it's not clearly written. I'll try to make it more clear. But to summarize, I was trying to say that in the past I was unable to use the host's keyboard shortcuts when the guest had the focus, but in the present, I am able to do this, but I'm now unable to use the guest's shortcuts, –  Marty Fried May 22 '12 at 3:50
    
Ok, I see what you mean. Which shortcut keys are you talking about specifically? For example ctrl-alt-del, ctrl-alt-bkspc, etc. have always been disabled, you need to use host-delete, host-bkspc, etc. Also, what version of virtualbox are you using and what is the guest OS? –  adempewolff May 22 '12 at 5:34
    
I know about the system keys like you mentioned. I'm talking about shortcuts like Alt-Ctrl-T to run a terminal, or Alt-Ctrl-left/right for switching virtual desktops, etc (with Ubuntu guest, such as for testing a new release). But I've had a Windows XP VM I've used for years to run iTunes and Quicken, and it also changed. I'm using Virtualbox 4.1.14r77440, and it says it's the most recent version. I think the previous version acted differently, so maybe I'll see if the release notes say anything. –  Marty Fried May 22 '12 at 19:00
add comment

2 Answers 2

up vote 3 down vote accepted

I just discovered something I've been missing - the "Preferences" menu item. I've gone through the settings for the individual VMs many times, but didn't notice that there was a separate "Preferences" menu for some reason. I opened this, and lo and behold, there was a checkbox under "Input" (where the host key is set, another thing I was wondering about) called "Auto Capture Keyboard". This was unchecked, for some reason, and checking this made it behave like it did previously.

It would be nice if this were set per VM, but the good news is that it can be changed while the VM is running, and takes effect immediately. So, problem solved. User is an idiot. :(

share|improve this answer
    
I don't think that he's an idiot. This "global setting" can't be reached by the settings-menu in the mini-toolbar. But if he is, I'm too. Took me some time to find the settings... –  user138399 Mar 7 '13 at 15:22
1  
By "he", you mean "me". I was answering my own post after figuring it out. I wouldn't call someone else an idiot (well, not without provocation). :) –  Marty Fried Mar 9 '13 at 2:39
1  
This helped in reverse too, I wanted the box unchecked so I can Alt-Tab out of the virtual machine. Bonus: This also lets me use Windows AutoHotkey scripts inside Linux! –  Zook Jul 17 at 15:54
add comment

Personally I'm experiencing this bug, I think: https://www.virtualbox.org/ticket/439

The Auto-capture keyboard settings don't help.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.