Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to bind the TapButton3 as central mouse button so i do:

synclient TapButton3=2

it works great but when i restart or wake up from suspension it forgets the setting. i know that i have to create the xorg.conf as follows

Section "InputClass" 
Identifier "touchpad catchall" 
    Driver "synaptics" 
    MatchIsTouchpad "on" 
    Option "TapButton3" "2" 
EndSection

but this doesen't work. anyone can help me? ...please?

share|improve this question
    
Make sure the path is /etc/X11/xorg.conf. The first slash is important. –  Chan-Ho Suh May 22 '12 at 2:24
    
yes off course, the path is correct. but is the xorg file that i wrote correct? –  Aldo DeeJay May 25 '12 at 9:45
    
Yes, your xorg.conf format is correct. How did you create/edit your file? –  Chan-Ho Suh May 25 '12 at 10:28
    
i type in the terminal: sudo gedit /etc/X11/xorg.conf –  Aldo DeeJay May 30 '12 at 19:24
    
I suppose there could be some complex reasons your setup isn't reading the conf file. The simplest would be perhaps you've inadvertently changed permissions. What do you get as output when you run: ls -l /etc/X11/xorg.conf ? –  Chan-Ho Suh May 30 '12 at 23:01

1 Answer 1

I created the /etc/X11/xorg.conf.d/71-synaptics.conf file with the following contents with sudo vi:

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        Option "TapButton3" "2"
EndSection

and I can see in /var/log/Xorg.0.log that the option has been set.

[ 91056.468] (**) Option "TapButton3" "2"

The option was merged with options I had set similarly in my 70-synaptics.conf file.

If your device uses a different device or different driver (see the /var/log/Xorg.0.log to see), you should adjust the Identifier and Driver lines appropriately.

Another approach is to disable the gnome mouse settings plugin.

  • To do this start a terminal with Alt+Ctl+T, and then install the dconf-editor:

    apt-get install dconf-editor hleinone

  • Launch dconf-editor

    dconf-editor

and navigate the tree to org.gnome.settings-daemon.plugins.mouse.

  • Finally, uncheck the Active box

A drawback of this latter approach is that no settings you configure in System Settings-> Mouse and Touchpad will be effective.

This approach, from the comments, is from here by way of hleinone.

share|improve this answer
    
I have the above configuration and still when I return from suspend the TapButton3 is back at 0. –  hleinone Jun 10 '12 at 16:44
    
@hleinone What does the /var/log/Xorg.0.log file say? Can you see that it doesn't set it, or that it sets it and sets it back. If the latter, when does the reset happen and are there any helpful messages around the time it happens? –  John S Gruber Jun 10 '12 at 16:55
    
I don't see it being set on the log. –  hleinone Jun 10 '12 at 17:05
    
I'd suggest that you look at the first 50 lines of your /var/log/Xorg.0.log file to your question. Mine says: Using config directory: "/etc/X11/xorg.conf.d" . If you still also have a /etc/X11/xorg.conf file both the file and the directory presumably should be listed. If it says that and you are sure of all the other details you might try adding a different option and see if the log says that is set (determine if it doesn't like the option in the file or if it doesn't find like the file). –  John S Gruber Jun 10 '12 at 18:07
    
Mine says: Using config directory: "/etc/X11/xorg.conf.d" and Using system config directory "/usr/share/X11/xorg.conf.d" No mention about /etc/X11/xorg.conf since it doesn't exist. –  hleinone Jun 10 '12 at 18:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.