Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04 64 bits. When I try to run spark 2.6.3 I get up the next error:

admini@localhost:~/Spark$ sh starter 
Preparing JRE ...
starter: 150: starter: bin/unpack200: not found
Error unpacking jar files. Aborting.
You might need administrative priviledges for this operation.

in version 11.10 running smoothly. Not sure what is happening.

share|improve this question
    
I think you need to be root to run that. try sudo -s your password then run the script –  user82356 Aug 9 '12 at 17:01

3 Answers 3

If you are using 64bit Ubuntu you need to install the ia32-libs Install ia32-libs library that the spark for work, to install in a terminal type
sudo apt-get install ia32-libs
restart the system and finally enter the directory where you installed Spark and the necessary permissions to read and execution totos users I gave permission
sudo chmod 777 Spark
but the permissions you see fit. Worked with me.

share|improve this answer

Worked for me after installing openjdk-6-jre:i386 and icedtea plugin (but I don't know if that's really necessary)

Let me know if that helps!

share|improve this answer

I ran this and it helped me:

mv jre jre.not sed -i 's/\/lib\/windows/\/lib\/linux/g' Spark/Spark

See http://dogma.swiftspirit.co.za/archives/tag/jre.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.