Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my Notebook (with Realtek ALC269VB) the sound over speakers works well until I plugin the headphones, Speakes get muted as expected but no sound on headphones. I noticed that as soon as I plugin the headphones, Alsamixer, Ubuntu Sound Control and pavucontrol switched to 'Headphones' which have no effect (does not really exist). When I switch back to 'Speakers' everything is fine; I can control the sound of headphones. This is a kind of work-around (starting pavucontrol to switch from Headphones to Speakers) but not relly satisfying.

My complete sound configuration and a screenshot of Alsamixer.

You may notice that Alsamixer says 'Intel Cougarpoint HDMI' instead of 'Intel HDA Realtec ALC269VB' what it did two days ago. Anyway, I couldn't find any differences between it.

My question:

In order to easy the work-around: is there a command line option to switch to 'Speakers'?

share|improve this question
    
Related: askubuntu.com/questions/71863/… –  Takkat May 22 '12 at 7:16
    
In the first place I'm looking for a solution that avoids the problem at all: How to avoid that an input (sound) is switched from sink 'Speakers' to a not existing sink 'Headphones' when I plugin my headphones? Thanks to Takkat for the work-around link. –  Ralf Hersel May 22 '12 at 15:50
add comment

1 Answer 1

up vote 2 down vote accepted

Pulseaudio always tries to switch to a newly available audio port when it becomes available. To stop this we can edit our default.pa. This file is located in /etc/pulse (defining settings for all users) or in ~/.pulse (to override these settings for a single user). Just comment out this line to stop pulseaudio from switching ports as follows:

# load-module module-switch-on-port-available

To take effect we need to restart pulseaudio server with pulseaudio -k (or restarting our session).

Whenever you edit the /etc/pulse/default.pa please make a backup first to be able to restore previous settings in case something goes wrong.

share|improve this answer
    
Yes, now it works perfectly. By the way, restarting the session is not enough but 'pulseaudio -k' makes it happen. –  Ralf Hersel May 23 '12 at 21:50
    
It works. Thank you. Now I have the same volume state for the speakers and headphones. Is it possible to save and restore the volume states when pluging/unpluging the headphones ? –  thomio Jan 26 at 15:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.