Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is my first time installing Ubuntu but I am having problems installing it on my Lenovo G570 laptop. I have downloaded the 12.04 desktop version, and booted it successfully, but when I choose to install Ubuntu, and I choose to install side-by-side with Windows 7, the CD ejects and I need to reboot. When I choose advanced partitioning, an error comes up, No root filesystem defined and I am unsure as to how to continue. I've tried wubi, but it requires a long download which I cannot complete due to a slow internet connection. Please tell me how I can resolve this issue.

share|improve this question
    
Welcome to Ask Ubuntu! As it stands, your question may need a little more information in order for it to be answered. If you are not technically savvy don't worry, just add as much information as you can, so that you can get an answer (and a good one at that). –  hexafraction May 21 '12 at 22:48
    
Are you still having this problem? If not, be sure to close this question by clicking the unobtrusive checkmark to the left of your desired answer to mark it as "Solved". –  hexafraction Jun 6 '12 at 20:32

1 Answer 1

When you select the partition to install, click on it, click edit, set the mount point to install in as / in the dialog. Then, try to install again. If this continues to fail, start the installer, then select advanced partitioning mode. Delete all of your partitions, and add anew partition. Set it to max size. Then, click OK to acknowledge this partition. Then, click edit when the new partition is highlighted and in the mount point dropdown, and select / as the mount point. Click OK to acknowledge, and try to continue installation. Hope this helps :-)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.