Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded my mini 10 to Ubuntu 12.04 and have been having the following problems. On a normal startup, the computer boots to a black screen. If I press F6 on startup and boot from the non recovery, I will get to the user selection screen. But, it by default wants to be in unity 3d so it only takes up the top half of the screen, bottom half is black. My understanding is that this is because its in Unity 3d not unity 2d. The file /etc/lightdm/lightdm.conf reads as follows:

[SeatDefaults]
autologin-guest=false
autologin-user=
autologin-user-timeout=0
autologin-session=lightdm-autologin
user-session=ubuntu-2d
greeter-session=unity-greeter

I am not sure what to do next. Any help would be great. Thank you

share|improve this question
add comment

2 Answers

Finally fixed this over the summer. Here's what I had to do.

Edit /etc/default/grub file

Make the GRUB_CMDLINE_LINUX_DEFAULT line looks like this

GRUB_CMDLINE_LINUX_DEFAULT="console=tty1 mem=896mb"

Install desktop-base

sudo apt-get install desktop-base

desktop-base does something to fix it, no idea what, but

GRUB_CMDLINE_LINUX_DEFAULT="console=tty1 mem=896mb" 

alone still has the split screen problem.

** NOTE - installing desktop-base adds the debian space background to grub boot menu. I believe you can remove this by deleting or editing /usr/share/images/desktop-base/desktop-grub.png

Or just leave it and enjoy the fact you can finally login without that annoying split screen.

Also, installing lubuntu-desktop helps a lot on the mini10, actually quite usable.

If you get a strange blank section between wireless icon and power icon.. right click on the panel, add-remove panel items. Remove the "system-tray" and add "indicator-applets"

If you want a unity look/feel, right-click the panel and customize the settings. Move it to the left, change the width to 35 or 40 pixels and change color to solid opacity with transparency or anything other than the default image. This setup closely resembles the unity look/feel.

share|improve this answer
add comment

I have the same problem on my dell mini-10. Black screen on boot....

Let the PC boot normally... to the black screen.. I hear the ubuntu login prompt telling me it loaded correctly.

press Ctrl+Alt+F6 to go to a tty6

[ which is Ctrl+Alt+Fn+F6 on the mini10 because it uses Fn to access the Fkeys on top ]

Then switch back to tty7

Ctrl+Alt+Fn+F7

You should see the login screen, and probably the bottom half of your screen is black.. like leftover terminal from startup. Login .. wait for everything to load... and logout again

Your screen will be fixed.

if you can't access the icons because your mouse goes all over the place, change back to tty6 and kill the gnome-session [killall gnome-session] it will close your session and bring you back to the lightdm login screen with correct resolution.

Strangely, my folds have the same PC and there's boots to the login on top and terminal on bottom... I think I deleted "quiet splash from the grub entry on startup." but dont remeber

I just did these updates over the weekend myself, so am also looking for a better way to fix this... almost like I need to restart x or something...

later,


edit -- this works better

Switch to a console - Ctrl+Alt+Fn+F1

Restart X with 'sudo service lightdm restart'

found at

https://wiki.ubuntu.com/HardwareSupportComponentsVideoCardsPoulsbo

Jahst

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.