Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was fooling around in the keyboard shortcut section, and accidentally changed the HUD's shortcut from Alt L to Mod 2 + Alt L.

Now, whenever I hold and even press the alt key, HUD will pop up. I don't have the option to hold the alt key, and then press F4 to close a window.

enter image description here

How can I get this back to normal? Every time I try too, I can never get the shortcut back to just Alt L.

share|improve this question
    
Here is an easier way. Make sure, Num Lock is NOT set. Now, set HUD display keyboard shortcut and you are done :) –  deshmukh Oct 4 '12 at 12:39
add comment

3 Answers

up vote 4 down vote accepted

You can use CompizConfig Settings Manager to change the key used to show the Unity HUD.

To open terminal hit Alt+Ctrl+T and run following command:

sudo apt-get install compizconfig-settings-manager

Or search for 'compizconfig-settings-manager' and install it from there.

Once installed, Hit Super key (Windows key) to open Unity dash and search for "ccsm" and open it.

In CompizConfig Settings Manager Navigate to Desktop > Ubuntu Unity Plugin

Under the Behavior tab click on little cross in front of "Key to show the HUD", This will set the key to default (Alt)

enter image description here

share|improve this answer
    
Thank you! I never thought of using ccsm. Thanks. –  TriforceLZG May 21 '12 at 22:46
add comment

You should be able to assign any key combination you like by simply clicking the row that reads "Key to show the HUD". Then the shortcut text will change to "New accelerator...". Then just press the left "Alt" key. ("Alt L" stands for your left Alt key.)

share|improve this answer
add comment

Due to a bug described here:

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/981628

you can't change HUD key from mod2+ ALt L back to Alt L.

The solution is quite simple, just turn NumLock off and try again.

You'll find the default setting is back again!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.