Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There was an update a few weeks ago that seemed to mess with anti-aliasing in some applications. Firefox, Thunderbird, and the text in some apps such as Mousepad and Leafpad (but not the rest of the window) are affected, whereas Chrome and everything else seems to be just fine. Attached are two screenshots showing the difference between rendering in Firefox and Chrome.

The anti-aliasing settings are the same as they've always been, which have worked just fine - full hinting, RGB sub-pixel order.

I'm really not sure what's going on and am thinking that it might be faster to fix this problem by re-installing, but is there anything I can try first as re-installing is the last thing I want to do?

I'm running Xubuntu 12.04.

Chrome Screenshot

Firefox Screenshot

share|improve this question

I fixed the font rendering on my system after reading this topic. Removing/renaming the home (profile) directory and starting over didn't make any difference.

You need to open the xfce4-settings editor and set the /Xft/Lcdfilter string in the xsettings channel from lcdnone to lcdlight. Other options to try are lcddefault and lcdlegacy as seen here under Rendering subtitle. Here is the CLI way:

xfconf-query -c xsettings -p /Xft/Lcdfilter -s lcdlight

or if the old value doesn't exist:

xfconf-query -c xsettings -p /Xft/Lcdfilter -n -t string -s lcdlight

After changing that option you need to restart the applications to see the differences. Here are my before and after screenshots (after is the like it was on 11.10). Btw, the screenshots are resized so you should right click on them and click View image or Open image in new tab to really see the differences.

Lcdfilter=lcdnone - ugly fonts Lcdfilter=lcdlight - pretty fonts like in 11.10

share|improve this answer
This fixed it for me, except that I used "lcdfull" instead of "lcdlight", assuming it matches the setting in the font configuration UI. – code_martial Oct 9 '12 at 5:49
This also worked for me (I used lcddefault), and it is a good answer and deserves to be the accepted answer. – user76204 Nov 1 '12 at 18:11
worked for me too. wonder why this has not been accepted as best answer. – JanD Nov 10 '12 at 21:29

Rename or delete file ".fonts.conf" in your home directory (switch on "display hidden files" to find it), log off and log on again.

This helped me (with ubuntu 12.10).

share|improve this answer
worked for me too, poor rendering of Serif in Firefox :) – Piyush Oct 29 '12 at 14:02


This occurs because your sub-pixel order is incorrect. Go to the Settings > Appearance. And then play with the sub-pixel order. If you are on a newer laptop, switching from RGBA to None does the trick. See the attached screen shot.

Settings > Appearance

share|improve this answer
The subpixel ordering was correct and hadn't changed. I'd tried all permutations of this. What I discovered is it was profile specific, but I've reinstalled now and can't try to correct it. – Matty May 28 '12 at 15:20

I'm not sure if it applies to xubuntu, but in Ubuntu standard I've had this crop up.

Solved it like this:

cd /etc/fonts/conf.d
sudo mkdir orig
sudo mv 10-hinting-slight.conf orig

(close and reopen affected apps)

share|improve this answer

I had this same problem. I found a work around that is not really practical. (I am using Intel i7 + good HD screen.) Normally I use hint full, antialias ticked.

When Quetzal was released I installed a new Precise and updated to Quetzal without any modifications, except disable overlay scroll bars and global menu. Then installed xfce from repository. (I did not install the whole xubuntu-desktop until I had all this sorted.)

At first xfce was OK except the default colors were a bit bland. After I jiggled with settings > Appearance and Window manager I opened a new Firefox window. The menu was good, but the page and toolbars were rainbows. But this was only in Firefox. On the same screen at the same time were other applications which rendered perfectly. (Synaptic and Appearance). By changing font settings and opening new windows of Firefox after each, I established that Firefox does not respond to antialias or hinting in the currently exposed background or foreground windows. I could set hinting none, antialias none, and see the very blocky fonts in most applications on the screen. But perfect fonts in Firefox. I decided that at some point in user space Firefox was getting antialias and hint applied twice on the same page.

My temporary solution was to open a new account with admin privilege, and put up with the bland theme till this is sorted. (Or keep my old partition.)

PS. I have noticed that not all themes are setup to be good for gtk2 and gtk3. So applying a theme in appearances or window manager is sometimes hit an miss. You change theme A to theme B then going back to theme A is different to what it was moments ago. Settings are not being cleaned up between themes.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.