Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In the past I routinely backed up my entire unencrypted /home folder with LuckyBackup (gui for Rsync) to an external HDD. I've had no problems seeing and manipulating the backed up data when accessing the external backup HDD from a LiveCD, another Ubuntu computer or even Win7.

I recently installed Ubuntu 12.04LTS on a new SSD and decided to enable /home folder encryption during installation. Now, when I do a backup of /home to my external HDD using LuckyBackup, I can only see the backed up data on the HDD when I am in logged in to Ubuntu 12.04. When I try to look at or manipulate the data from a LiveCD, another Ubuntu computer or Win7 the data is not accessible and has a user 1000 permission set which can not be changed.

I conclude from this, that all of my backed up data is now saved on my external HDD in encrypted form. I did not expect this, nor do I want it. I want the backed up data saved in unencrypted format so I can access it from other OS's.

Question: Is there a way to backup an encrypted /home partition's data in an unencrypted format, read/copy/executable by any other OS?

share|improve this question

If you want to backup the cleartext versions of these files, you'll need to do two things:

  • You'll need to be logged in and your home directory will need to be mounted when your backup job runs.
  • You'll need to backup your actual home directory, such as /home/$USER, rather than just /home.

Full disclosure: I'm the author and maintainer of Ubuntu's Encrypted Home Directory feature

share|improve this answer
I didn't enabled the encryption of my home during installation, can I enabled it now or is it recommended to re-install Ubuntu and enable encryption during the install? – Max May 27 '12 at 8:51
This is a very reasonable question, but it should be asked as a new question of its own, and not a comment here. Thanks! – Dustin Kirkland May 28 '12 at 2:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.