Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did a fresh install of Ubuntu 12.04 (dual boot with Windows 7) on my sony Vaio. After the fresh install everything was working fine. then

  1. I was informed that new driver were available for my ATI video card (I first tried to install the post-release one but it was not possible so I selected the one tested by canonical)
  2. After that I noticed a bug where my laptop was rebooting instead of resuming from hibernate (i.e if I was closing the lid .. the laptop was hibernating but if I was opening the lid the laptop was shutting down)
  3. It was a bug I already experienced in 11.10 and I fixed it by amending the grub file from GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_sleep=nonvs" ... the fix sorted out that issue but introduced a new issue .. now when I shutdown my laptop it hangs on the splash screen (Ubuntu logo with the 4 dots) and nothing happens.
  4. I tried to use the following fix GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force splash acpi_sleep=nonvs" but it is not working.

Any help in fixing this would be appreciated.

PS: after 5 years using Ubuntu this is the first time I am not able to find the solution within a week

share|improve this question
    
The fglrx driver will cause our computer to hang while shutting down. I had reported the bug here. bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/995184 –  Emerson Hsieh May 28 '12 at 20:33
add comment

4 Answers

Solved by doing the following:

I've rolled back the grub file as it was originally (only quiet splash option), then:

update-grub
sudo apt-get install fglrx-updates
sudo aticonfig --initial
update-grub

Looks like that installing ati driver from the ubuntu driver update GUI is not a smooth process.

share|improve this answer
    
You can accept your own answer later. –  Andrejs Cainikovs May 22 '12 at 20:08
    
This didn't work for me on Thinkpad t500. Same problem here, after installing fglrx-updates shutdown hangs forever –  Janning May 28 '12 at 21:04
    
    
This is the correct answer! I just posted it again with a picture of my bios setting. –  Janning May 28 '12 at 21:44
add comment

Mybe wrong to post it as an answer but i wanted to add an image:

with my Thinkpad T 500 shutdown hangs after aptitude install fglrx-updates fglrx-amdcccle-updates.

I needed to change BIOS settings like this:

enter image description here

and then i ran

sudo update-grub
sudo apt-get install fglrx-updates
sudo aticonfig --initial
sudo update-grub

It worked for me.

share|improve this answer
    
Did your Ubuntu splash screen shows up ugly? (I mean low- res) –  Emerson Hsieh May 28 '12 at 21:59
    
First yes, but i think this is another problem, which i fixed by "cp /usr/share/grub/*.pf2 /boot/grub && update-grub" see bugs.launchpad.net/ubuntu/+source/grub2/+bug/699802 –  Janning May 29 '12 at 7:51
    
Thanks for the bug link! And I thought I was the only person in the ubuntu community that got the low -res boot screen after install the drivers. –  Emerson Hsieh May 31 '12 at 2:00
add comment

sudo update-grub fixed my 12.04 shutdown problem.

share|improve this answer
add comment

You could try this, it may help:

GRUB_CMDLINE_LINUX_DEFAULT="acpi=off apm power_off=1 quiet splash"

Then run sudo update-grub and restart.

This fixed the problem on my notebook.

share|improve this answer
    
Thank you for your answer ... do you know where I can find the meaning of all the options we can pass to GRUB_CMDLINE_LINUX_DEFAULT ? Apart from quiet splash I have no idea of what the other options mean ... Thank you –  kaizer May 22 '12 at 8:49
    
@kaizer You might want to post a new question asking if there is an online source that lists and explains all possible Linux kernel boot options. I'm not sure if there's a good current source for this, but if so, it would be quite valuable. –  Eliah Kagan May 28 '12 at 20:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.