Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Looks like I have some problem here. I'm trying to play some games on my notebook with Ubuntu 12.04. But all games I treed to play have dark textures. 2D objects (like menus and buttons) are NOT affected.


share|improve this question
Found bug but it is about i965. I have i915 and solution dont make effect. – Undesired May 21 '12 at 17:24

Try updating graphics drivers, which is done by adding PPA repository. Most popular is Xorg-edgers, but this sometimes breaks system, because it influences on many components. I rather use OIBAF updated video drivers, which only updates graphics Read here more. And don't forget installing S3TC (libtxc-dxtn0), to use "patented" textures comression (this might be problem with black or missing textures)

share|improve this answer
I had the same problem reported by Undesired, and this solution helped just fine. – estebanknobl Jan 3 '13 at 19:38

First of all, make sure your wine is up-to-date.

Copy and paste this on the Terminal:

export MESA_EXTENSION_OVERRIDE="-GL_EXT_texture_sRGB_decode -GL_ARB_draw_elements_base_vertex -GL_ARB_map_buffer_range"

After that run the game using wine game.exe, where game.exe is your executable.

If you prefer, put this command in .gnomerc or .profile file in the HOME directory, so that you do not need to put this command every time you launch the game.

I'd had a similar problem with my Intel GMA4500 (Laptop too), and that fixed it.

PS: Make sure you have driconf installed sudo apt-get driconf, open it through the terminal and enable the S3TC texture compression.

share|improve this answer

I was able to solve the problem simply by switching to Kubuntu. It solved the 3stc rendering issue using its Plasma desktop - aimed at making 3-D games run better - and made a huge difference with LOLegends.

Good luck,


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.