Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The brightness keys on my Dell N4010 with Ubuntu 12.04 is causing ubuntu to freeze on a black screen if i press the BrightUp and BrightDown key(s) 3-4 times. I think this is a bug which was noticed in 10.04 and was patched, but its giving problem in 12.04 again to me. I tried remapping and disabling the brightness keys but it did not work out. Please help.

share|improve this question

2 Answers 2

Edit "/etc/default/grub" as root.

gksu gedit /etc/default/grub

Now, look for the line that looks like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Append "acpi_backlight=vendor acpi_osi=Linux" to the end of that line, before the end quotes, so that the line now looks something like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi=Linux"

Save and close the file, and run the following command:

sudo update-grub

Now, reboot, and test out the brightness keys. They should be working correctly now.

share|improve this answer
    
This worked before, on my ubuntu 12.10. Not working anymore on ubuntu 13.04. –  FRD Jul 23 '13 at 9:40

I've managed to get this bug solved!

The answer is here: http://ubuntuforums.org/showthread.php?t=2181534&p=12819813#post12819813

Create the file /usr/share/X11/xorg.conf.d/20-intel.conf with the following content:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"

EndSection

Log out to see if it works.

share|improve this answer

protected by Community Jan 17 at 16:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.