Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried using Ubuntu 12.04 LTS using a USB Stick, but the desktop resolution is really low - every icon and piece of text looks pixelated. I have a

`ViewSonic VS10866 monitor : 19" 
LCD display, 16:10 aspect ratio, 
300-nit brightness, 500:1 contrast ratio`

. How do I fix this resolution problem? The last time I used Ubuntu, it was version 10.04 which worked perfectly fine. So what's wrong now? I currently only have Windows on my machine, which I plan to run along with 12.04.

share|improve this question
The essential piece of info, which is missing, is the graphics you have, not the kind of monitor, size of display, etc. – Chan-Ho Suh May 22 '12 at 17:43

I have the same problem because I use a KVM switch with analog ports.

Being not digitally connected it seems that my 16x9 screen is not detected.

I hate these automatic detections mechanisms which frequently fail.

Developers these days try to build more fancyness than real value.

Why can't there be easy manual overrides?

On Windows these things work much better than on Linux.

I found that I can use cvt 1920 1080 60 to get the mode settings for my display.

I use:

xrandr --newmode "1920x1080_60" $(cvt 1920 1080 60 | grep Modeline | sed -re 's~.*"(.*)_.*"~\1~')


xrandr --addmode VGA1 1920x1080_60

Then I can see the new mode in the display settings and select it.

Unfortunately it is not persistent on reboot.

share|improve this answer
I also have a similar problem with my KVM switch with VGA ports, but if I enable the right channel before starting the computer and stay on it until the system has started, I don't have any problem, because the monitor is correctly identified by Ubuntu. However If I am working on another computer while starting another with Ubuntu, the resolution detected will be 1024x768 or lower only. Same phenomenon under Windows 7 but not XP. – Golboth Jul 29 '12 at 9:05
getting error on --admode X Error of failed request: BadMatch (invalid parameter attributes) Major opcode of failed request: 141 (RANDR) Minor opcode of failed request: 18 (RRAddOutputMode) Serial number of failed request: 39 Current serial number in output stream: 40 – lenzai Dec 3 '13 at 4:31

The first post did the trick for me with a slight modification; Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below:

xrandr --newmode $(cvt 1920 1080 60 | grep Mode | sed -e 's/.*"/1920x1080/')
share|improve this answer
xrandr --newmode $(cvt 1920 1080 60 | grep Mode | sed -e 's/.*"/1920x1080/') – atilkan Aug 21 '15 at 4:44

You could try for:

sudo jockey-gtk

which searches and downloads applicable drivers for you.

share|improve this answer
It downloaded drivers for me, but didn't solve the resolution problem. – LeeGee Mar 10 '14 at 18:57

Follow these instructions.

In Ubuntu 12.04 LTS, we can use grub-customizer to fix the problem:

1. Start your machine, on ‘signal out of range’ screen press Enter. Wait a second (or try Ctrl+Alt+F1, Ctrl+ALt+F7), it will boot into Ubuntu.
2. Once boot into Ubuntu, configure the network and install grub-customize by running following commands in terminal:

sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get install grub-customizer

Or directly download and install the deb from
3. Launch grub-customizer. In its Preference window second tab, check and change the resolution. Remember to click ‘Save‘ the configuration 

Not working for me but I'm slowly getting to the bottom of it.

Instructions from

share|improve this answer

Do you have an accelerated graphics card? You may not get the correct resolution until you install the appropriate driver.

Try out the solutions here The part headed Not recognised video cards might be the appropriate part for you both but not sure about Amen as he does not say what type of graphics he has

share|improve this answer

The resolution should be properly detected and set on digital connections like DVI, HDMI or DisplayPort. Unfortunately that particular model does not even seem to have a digital port. If it has try a digital cable, if not try another analog cable to be sure that it's not a hardware issue. You can add custom modelines which are responsible for proper resolution detection, but instead I would suggest using a digital connection and replacing the monitor if needed.

share|improve this answer

It is possible that your monitor is not correctly detected because it can not be identified properly. It is a relatively common problem which affects Ubuntu as well as Windows with some monitors. If you are encountering this problem, you simply have to shutdown the computer, unplug the power cord of your monitor for more than 15 seconds (to ensure all the capacities are emptied). Then plug back the power cord of your monitor, power it on and start your computer with the Ubuntu 12.04 on your USB stick. Your monitor must always be powered on before starting the computer, otherwise the resolutions detected may be incorrect. This is true for Ubuntu as well as latest versions of Windows (at least if you don't use official proprietary drivers from nvidia or else).

If unplugging the monitor for a short time does not solve the problem, you should propably try to install the right proprietary driver for your graphic card via "Additional drivers" or by following the post of Chris Carter if no proprietary drivers are available there.

Depending on the problem you are effectively facing, following the solution of Peter may help too.

If you receive a message "signal out of range" or equivalent from your monitor during Ubuntu startup, the solution of Jo Boxer may help.

share|improve this answer

@Peter: This has nothing to do with windows being better. It's most likely a hardware issue of the monitor. The powersupply is going bad and no longer provides the voltage or current to keep the PNP signal that provides the information at the correct level, thus the video card can't 'hear' it clearly anylonger, that on it's turn decides to conclude that therefore the monitor is an old generic one that doesnt provide any PNP resolution data. This is then communicated to the OS. The OS then finally switches the resolution back to the stoneage. MANY monitors have this issue (almost looks like a design feature to phase out old displays and encourage people to buy new) Now, setting XRANDR to the correct value, is a nice workaround but it just doesn't repair the monitor. I would like to see an option in the display settings that can switch on an option to be able to select these resolutions from the GUI so that EVERY GNU/Linux user (also the ones who don't have a clue about the console) can save some money.

This defective PNP feature smells a lot like DRM. Just look at the scale of it. Most people don't have a clue and like good slaves carrie themselves to the shop to waiste more money on a new one that will mostlikely have the same issue...

So please don't fool yourself thinking that another OS is any better with detecting PNP data.

To make the OS better: then include all resolutions in the GUI, only use PNP for conveiniance. But don't play in the had of corporations who like to lure consumers back to the shop as soon as possible.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.