Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.04 LTS on my Packard Bell EasyNote TS11HR-127GE laptop and I cannot adjust the brightness. If I change the slider, the brightness is always at maximum. My laptop is using NVIDIA Optimus and has a integrated Intel HD 3000 and a NVIDIA GT540M graphic card. I already installed the newest Bumblebee version but this has also no effect.

Anyone an idea?

Here is the output of lsmod:

Module                  Size  Used by
bbswitch               13396  0 
parport_pc             32866  0 
ppdev                  17113  0 
bnep                   18281  2 
rfcomm                 47604  0 
bluetooth             180104  10 bnep,rfcomm
binfmt_misc            17540  1 
snd_hda_codec_hdmi     32474  1 
snd_hda_codec_realtek   223867  1 
snd_hda_intel          33773  3 
snd_hda_codec         127706  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              13668  1 snd_hda_codec
snd_pcm                97188  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
arc4                   12529  2 
snd_seq_midi           13324  0 
snd_rawmidi            30748  1 snd_seq_midi
snd_seq_midi_event     14899  1 snd_seq_midi
snd_seq                61896  2 snd_seq_midi,snd_seq_midi_event
ath9k                 132390  0 
snd_timer              29990  2 snd_pcm,snd_seq
snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
mac80211              506816  1 ath9k
uvcvideo               72627  0 
snd                    78855  16 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
videodev               98259  1 uvcvideo
soundcore              15091  1 snd
snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
psmouse                87692  0 
joydev                 17693  0 
v4l2_compat_ioctl32    17128  1 videodev
serio_raw              13211  0 
ath9k_common           14053  1 ath9k
ath9k_hw              411112  2 ath9k,ath9k_common
ath                    24067  3 ath9k,ath9k_common,ath9k_hw
cfg80211              205544  3 ath9k,mac80211,ath
i915                  468651  3 
drm_kms_helper         46978  1 i915
drm                   242038  4 i915,drm_kms_helper
mei                    41616  0 
i2c_algo_bit           13423  1 i915
mxm_wmi                12979  0 
acer_wmi               28418  0 
sparse_keymap          13890  1 acer_wmi
video                  19596  1 i915
wmi                    19256  2 mxm_wmi,acer_wmi
mac_hid                13253  0 
lp                     17799  0 
parport                46562  3 parport_pc,ppdev,lp
usbhid                 47199  0 
hid                    99559  1 usbhid
tg3                   152032  0 
sdhci_pci              18826  0 
sdhci                  33205  1 sdhci_pci
share|improve this question
add comment

4 Answers 4

up vote 2 down vote accepted

Finally this worked for me.

gksudo gedit /etc/default/grub

Change the line:

GRUB_CMDLINE_LINUX=""

to

GRUB_CMDLINE_LINUX="acpi_osi=Linux"

Then run sudo update-grub and reboot.

(source)

share|improve this answer
add comment

Try adjusting the brightness with the button on you laptop, usually a Fx key. I am assuming you have tried to adjust with the software 'slider' but I'd try again after testing the hardware button.

If this does not work consider installing proprietary drivers.

share|improve this answer
    
I already tried using my Fn keys but this is also not working. I think I am using Bumblebee using the proprietary driver ( related to the installation instructons from the bumblebee homepage bumblebee-project.org/install.html#Ubuntu ). –  Mr.Mojo May 20 '12 at 14:06
    
Consider booting into BIOS and trying to set the brightness there? –  pfindan May 21 '12 at 18:28
    
In BIOS are no settings for brightness, I also already made a BIOS update! –  Mr.Mojo May 22 '12 at 17:18
add comment

Try this:

  1. Open a terminal (Ctrl+Alt+T).
  2. Then type sudo nano /etc/default/grub. It will ask for your password. Type it in.
  3. Around the 11th line, there will be something like:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    Change it to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
  4. Save the file by Ctrl+O followed by Ctrl+X. Then run sudo update-grub in the terminal.
  5. Reboot and see if backlight adjustment works. If not, undo the changes you did above, by invoking the text editor as in steps 1 and 2.

Hope it helps. Credit to this answer.

share|improve this answer
add comment

Same solution as one-liner

For this solution no nano knowledge is required. It is also handy for multi-machine installation scripts. This was tested on a Packard Bell Easynote TE11HC with Intel graphics.

sudo sed -i 's|^GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"|GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"|' /etc/default/grub && sudo update-grub
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.