Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can i play .ts files in Ubuntu? I would prefer if you could recommend a codec instead of a new piece of software, so I can use any software to play.

And is there any codec pack that make me sure I will be able to play all ordinary media files? Something similar to k-lite codec pack.

note: some of my .ts files already can be played with SMplay, but just some...

PS: as i mentioned above i already can play some .ts files. and i have ubuntu-restricted-extras and mplayer and samplayer in latest version. the problem is that some .ts files that open in windows systems do not play in my ubuntu 10.04

share|improve this question

5 Answers 5

up vote 5 down vote accepted

I recommend smplayer and gecko-mediaplayer, which are the best mplayer frontend and browser plugin respectively. For codecs get ubuntu-restricted-extras. I also recommend the Comprehensive Multimedia & Video Howto tutorial.

smplayer Install smplayer

gecko-mediaplayer Install gecko-mediaplayer

ubuntu-restricted-extras Install ubuntu-restricted-extras

share|improve this answer
    
It's possible (if it's legal to do so) that you need to install libdvdcss from the Medibuntu repository. Follow the instructions at help.ubuntu.com/community/Medibuntu, then do a sudo apt-get install libdvdcss2 –  Scaine Nov 20 '10 at 10:24
    
thanks, i will give it a try and report here –  Alexar Nov 21 '10 at 13:23
    
i installed packages referenced in Howto (ubuntuforums.org/showthread.php?t=766683) and now they can be played with SMplayer. thanks. –  Alexar Nov 23 '10 at 9:14
    
You are welcome @takpar. Never had any video codec problems since I started to use that tutorial. –  lovinglinux Nov 23 '10 at 11:02

Smplayer can play this type of videos but you cannot rewind or fast forward. You can only watch it. I run Linux Mint 17 and all multimedia files play normally except .ts files which play in Smplayer only. I have installed the following packages ubuntu-restricted-extras - Smplayer which are not installed by default in Linux Mint 17. I hope this can help. Edited from this point :) I do a work around to solve this issue I use WinFF app to convert the .ts file to any other file that play normally which in my case I prefer the following settings in winff ( sorry I am not allowed to upload images to illustrate the description provided )

Convert to : ( I choose DVD ) Preset ( I select PAL DVD fast LQ)

Preset settings can change according to your needs of course :) Cheers

share|improve this answer

Your problem is likely arising from the fact that some files are encrypted and in such a cases, they will play on windows, but not ubuntu, and there is little we can (or should) do about that.

share|improve this answer

Try this solution then, install mplayer-nogui and play your video from terminal.

mplayer-nogui Install mplayer-nogui

Playing video from terminal:

mplayer /path/to/your/video/file

Almost all the video's can play here.None of the video's failed for me but i have never tried .ts video files..Let me know if it works for you..

share|improve this answer

.ts is actually .mpg. To me (Ubuntu 12.04), totem can play .ts video file after I've renamed the file from .ts to .mpg...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.