Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My update center has started saying "package broken". It looked like it was vlc so I ran sudo apt-get update, also uninstalled vlc. For hours it worked and now when I download an app in software center it installs so slowly I just cancel it.

In the update center when it's updating the cache it never gets done. Does anyone know how to fix this? It seems it happened after the last updates.

Also after uninstalling vlc if I tried to get it from software center it said package broken, but installing it from a terminal works. I've tried update and upgrade from terminal and also did a partial upgrade.enter image description here*update*this morning I got up and opened the update center.Ihad 3 updates in there so I clicked check for updates and it said waiting for apt-get to close.I then closed out and reopened and trying to update cache was still slow.So I decided to try and install the updates already there and the pic attached is what I got.I dont know if you can read it well but the error has something to do with python sso client here

share|improve this question
Lot of problems with installations here in the past hours (Ubuntu OS, applications, updates). My Ubuntu 12.04 LTS got stucked on installation - "Processing triggers for update-notifier-common". Fas as I see, there are some problems with Canonical servers, we might wait 1 or more days to see the things sorted out. – Dave May 20 '12 at 1:06
lol ok atleast i m not the only one so that s a good thing I think.I guess about right now I really dont think I want to hear anyone bashing windows anymore,lol,I have never in my life had to fight issues daily with an os like ubuntu.But on the bright side I guess I m learning more and more on keeping an os going,lol.Look at me I m a miniature Billy Gates lol.I thought this 12.04 was out of beta? – robert May 20 '12 at 1:11
There are a lot of canonical server download issues at the moment: ( – fossfreedom May 20 '12 at 19:10

Change your update manager server to best server from settings of update manager.

and add this in your terminal:

sudo apt-get install -f
sudo apt-get update 

This may not completely fix the problem, as some packages come the from main server no matter what mirrors you're using.

2nd :::

  1. Make sure that you have enabled the all PPA in settings of update manager at other TAB& try again .
  2. what ever the process you are doing just try to do it from the terminal , then it will ask you yes/no . by giving yes you can get those things with out any errors .
share|improve this answer
already tried it raja but thanks for trying definitely – robert May 20 '12 at 2:48
Hello belacqua.Your editing is greatly appreciated but your answer still wont work.I ve tried that as well.But I left you with the word "wont"so you can come back and edit it to will not. – robert May 20 '12 at 3:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.