Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using 12.04. I recently noticed that I can't copy/cut/move files on the desktop, Unless I open Nautilus and go to the Desktop folder to complete the actions.

enter image description here

share|improve this question
    
Am I correct in guessing I am the only one having this intermittent problem? I'd really like to quash this little bug. –  uRock May 24 '12 at 0:15
    
Just wanted to chime in that I am having the same problem with a 12.04 64 bit fresh install. Changing permissions as described above fixed the problem....but the problem came back. I am exploring Gnome 3 at this point, for this reason as well as the restrictive nature of customizing Unity. Also, the spinning cube has a known bug. The bug has been posted on Launchpad since 11.10. It was the easiest way to change virtual desktops...but I can't use it in Unity with the bug. –  user67330 May 31 '12 at 2:26
    
This is a reported bug: bugs.launchpad.net/ubuntu/+source/nautilus/+bug/988251 . So, sorry for the bounty offered, but the question became off-topic. –  Radu Rădeanu Aug 10 '13 at 5:10
    
@searchfgold6789 - I have refunded your bounty since this is a confirmed bug report and as such this Q is off-topic as per the FAQ. –  fossfreedom Aug 12 '13 at 21:14
    
@fossfreedom Thank you, should have smelled this! –  searchfgold6789 Aug 13 '13 at 1:18
show 1 more comment

closed as off-topic by fossfreedom Aug 12 '13 at 21:14

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – fossfreedom
If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

Some Background:

With the changes to Ubuntu (starting in 11.04) the Unity menu-bar (icons, folders, at left-side of screen) replaced the desktop as the place for icons, launchers, etc.

It is possible to get limited use of the desktop by changing certain settings, but the intent is to no longer use the desktop for this purpose.

The other alternative is to revert/change to using Gnome desktop.

share|improve this answer
    
With 11.04 and 11.10 I was able to alt-click and complete these actions. My other machines running 12.04 are able to do these actions as well. This has only recently become a problem with this machine. –  uRock May 20 '12 at 0:34
    
Which of these are a clean/new install of 12.04, vs. an upgrade? –  david6 May 20 '12 at 1:17
    
I have three ubuntu 12.04 installs. One upgrade and one clean install work fine. My production machine is an upgrade. Right-click was working fine in the beginning and just recently started graying out those selections. –  uRock May 20 '12 at 1:31
    
SORRY. My main machines are an 11.10 (32-bit) and a new install of 12.04 (64-bit). Neither have any visible desktop icons, so unable to assist further. –  david6 May 20 '12 at 2:56
1  
I find this to be very unhelpful. I have been a member of the ubuntu community since 2009 and have not seen any documentation stating that ubuntu/Canonical plans to do away with icons on the desktop. I was under the impression that askubuntu was for questions and answers. Not the implication of opinions. –  uRock May 20 '12 at 19:34
add comment

check the permissions of your Desktop directory

ls -l ~ | grep "Desktop"

it looks like a permission problem, try changing permssions with this

sudo chmod 755 ~/Desktop -R
share|improve this answer
    
Permissions are correct. 8) –  uRock May 20 '12 at 1:34
    
i guess you could try reinstalling nautilus –  supermariolinux May 20 '12 at 1:36
    
I can use right-click within the desktop folder in Nautilus. I only have problems when right-clicking files on the desktop itself. –  uRock May 20 '12 at 1:41
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.