Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I click on any file eg php file it open by default in gedit I want that it will open by default in quanta plus

share|improve this question
up vote 1 down vote accepted

Right click on the file -> select 'Properties' -> go to the 'Open With' tab -> select the text editor of your choice from the list.

I believe that will make the text editor you choose the default for that particular file type. You'll have to repeat those steps for every file type though (e.g. plain text file, .log, .txt, etc.)

Just saw, but this question was already answered in a general form here: How do I change the default text editor?

share|improve this answer
Hmmm its great its doing work successfully but having bit issue when i open two file then there two editor open.if i open 10 file than it will open one editor for each file mean open 10 editor. – shalu Nov 19 '10 at 10:55
Thanks for reply. – shalu Nov 19 '10 at 10:56
I think this issue with opening multiple instances of the text editor instead of tabs (which it sounds like you want) is an issue with your text editor's settings, not with it being a default editor or not - so it's a different question. If this answer solved the question you ask please mark it as the accepted answer. If you have a new issue with your text editor please check your text editor's documentation and/or ask a new question. – Jay Nov 19 '10 at 11:27

The easiest way I found to change mine to gvim (I think it should work the same for your editor) was to add text/plain=quanta.desktop to ~/.local/share/applications/defaults.list and restart nautilus.

share|improve this answer
~/.local/share/applications/defaults.list not found this location – shalu Nov 19 '10 at 6:14
I m not found the defaults.list.Please reply its very urgent – shalu Nov 19 '10 at 6:47
If you don't have one but still have the ~/.local/share/applications, I'm pretty sure you can just create it. – wdkrnls Nov 23 '10 at 22:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.