Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 12.04 on my computer. At first it worked just fine, but when i started updating the system just "updated" the screen, and then freezed. Same thing happens when I log in. Any tip?

share|improve this question
    
I had a similar problem. My machine has a 'hybrid' Intel / AMD graphics setup. If you have the same, you may find you installed the AMD driver when updating your system. When the AMD driver is installed, the screen 'freezes' after you log in. To fix it, I followed the instructions in post 107 on the following thread: ubuntuforums.org/showthread.php?t=1930450&page=11 –  tardomatic May 21 '12 at 18:49
    
Welcome to Ask Ubuntu! This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  fossfreedom May 21 '12 at 21:37
add comment

closed as off topic by fossfreedom May 21 '12 at 21:37

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

I had a lot of problem when updated to 12.04.

What i've done was in a console ( ctr + alt + f1 ) to uninstall the packages xserver-xorg, ubuntu-desktop (and fglrx packages because i have an ati)

To uninstall: sudo apt-get remove --purge xserver-xorg ubuntu-desktop

After doing this you may have uninstalled some usufull packages like gnome. Before uninstall check the packages that apt-get uninstalled to manually do that when you reinstall again the packages.

sudo apt-get install xserver-xorg ubuntu-desktop

--------- [init] DO YOU HAVE AN ATI?---------------- sudo apt-get remove --purge fglrx*

Then try to install your graphic card drivers property. If you have an ati:

http://support.amd.com/us/gpudownload/Pages/index.aspx (download it before you uninstall these packages)

I also recommend do check this post: X doesn't start after Upgrade from 11.10 to 12.04

--------- [END] DO YOU HAVE AN ATI?----------------

Before you try this you can also try to run the command:

apt-get install --reinstall xserver-xorg ubuntu-desktop

Good luck.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.