Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I keep getting the "Java plugin out of date" box whenever I open a page with embedded Java. I use the link provided, which has no auto-install. I've unzipped the tarball into /usr/lib/jvm/. I've used chrome://plugins to check the current version, extracted the path from the details to verify the correct file, and manually edited .config/google-chrome/Default/Preferences to update the information for Java.

When I reopen chrome, it overwrites that Preferences file, thereby losing all the changes. I cannot find any documentation on how to update this. It's becoming rather frustrating, and is preventing me from using some software required by my school so I can view assignments, etc.

The current path of the plugin: /usr/lib/jvm/java-6-sun-1.6.0.26/jre/lib/amd64/libnpjp2.so

The desired path of the plugin: /usr/lib/jvm/jre1.7.0_04/lib/amd64/libnpjp2.so

Any help would be greatly appreciated!

share|improve this question

1 Answer 1

up vote 6 down vote accepted

Chrome will look for the plugin in Firefox's plugin directory, so make a symbolic link from your java installation to there:

ln -s /usr/lib/jvm/jre1.7.0_04/lib/amd64/libnpjp2.so ~/.mozilla/plugins

Then restart Chrome, check chrome://plugins again and disable the old plugin.

share|improve this answer
    
I deleted my previous comments, as even though the folder didn't exist, by creating it and then doing the symlink, it worked. Thanks! –  Tom Thorogood May 21 '12 at 22:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.