Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an i5 2500K and nvidia 9600 GT with proprietary driver. For some reason, this set up on 12.04(and was same on 11.10) seems to work fine on boot up, but after about 30 mins of use, games and other accelerated surfaces start running at about 5fps. This is fixed by a reboot to start it all over again. Is there some way I can get rid of this, as I don't have this problem with other systems with Ubuntu?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

It seems most the issues are removed upon disabling Composting in the xorg.conf file. Wish there was a fix for this, but this workaround works for now.

share|improve this answer
add comment

Your computer is processing too many things at once and the things that you are processing may take up a lot of memory which slows down the computer, plus you may be running more than one program.

The way you can fix this is by turning off the effects that comes as the default, or you can buy more memory for your computer, or run one thing at a time, which I think is going to be a problem for you because you want to run more than one program at a time.

So just get some more memory or turn off the effects in desktop preferences then click on effects and then click none effects, because it works like magic without the full effects on.

share|improve this answer
    
It was hard to originally read your comment as you made it all one sentence and used vague wording, but I don't think what you are mentioning is the problem. This happens in Unity2d along with when nothing else is running. –  eyecreate May 19 '12 at 1:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.