Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Application windows randomly snap either to the top or bottom of the screen, and won't be budged I can move them from side to side but they're locked either at the top or the bottom and on some occasions side to side. It's never the same window two sessions in a row, but it is extremely annoying. It happens randomly and will continue to do it for that particular application window for the entire session if I log out and log back in it will be a different application window. It's the only machine that does it, we have two machines running 12.04, and it's also the only machine running the Gnome Fallback Sessions. Other than just don't use Gnome I need some kind of answer, the EU won't consider using any other desktop environment except the Gnome Fallback.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I think I had the same problem, for me the solution was here: http://earlruby.org/2012/04/getting-rid-of-self-resizing-windows-in-ubuntu-linux-12-04/

Those settings should NOT lead to that kind of extreme behaviour (I resize VLC to a tiny window - it snaps back to full height!), but turning them all off solved it for me.

share|improve this answer
    
It seems to be some strange interaction between Compiz and the Gnome Fallback Session, the issue isn't present in the standard Gnome 3. The solution you provided was a great temporary solution but the issue returned after a few weeks. Since this particular EU must use Gnome Fallback and will not accept any other desktop environment or distribution, I'm going to recommend that he return to a MS Windows environment. Thanks for the link, and I'm sorry it took so long to respond. –  drassx15 Jun 20 '12 at 3:02

I went through http://earlruby.org/2012/04/getting-rid-of-self-resizing-windows-in-ubuntu-linux-12-04/ and posted the steps here. I actually did that myself and it worked! Although that is a permanent fix for me.

First see:

Then:

  1. Install Compiz-Config Settings Manager from the software Center. enter image description here

  2. Go to Applications > System Tools > CompizConfig Settings Manager. enter image description here

  3. Scroll down to Window Management and Uncheck it. enter image description here

  4. Click Back, then click Grid. Go to Edges and then click Resize Actions. Change all actions to None. enter image description here

Note: CompizConfig may leave you to an unusable desktop at this point. To fix that, revert all the actions by clicking the Backspace icon on the right of every action. Click back and try again. This is what my desktop looked like.

enter image description here

You are Done!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.