Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I execute Wine in Steam, everything goes alright, except Steam Game Overlay

I have check if it is activated in steam, if my hot key combination is alright and everything, but I still don't get in-game community to work.

Any help is appreciated.

share|improve this question
Have you tried looking further down in the link provided by @reverendj1 where it says ­winetricks sets up some compatibility overrides/defaults that are written directly in the STEAM client localconfig.vcf configuration file...­ and using those flags? – RobotHumans May 18 '12 at 21:51
I'm not too familiar with winetricks. What do i have to do to make winetricks do this thing? Thanks! – GamerPie May 19 '12 at 10:12

According to this: that is a known issue using Steam with Wine...

share|improve this answer
It says the tihng that acts weird sometimes is Steam Cloud, which is not related to that. Thanks anyway! – GamerPie May 18 '12 at 21:18
Keep scrolling. There is a lot of info on that page. I was referring to this: "Steam Community In-Game does not work - disable or it may cause games to crash or slow-down." It says it under known issues. – reverendj1 May 18 '12 at 21:47
I have found that line, but not the solution "above" as it says. I'm either blind or just stupid. – GamerPie May 19 '12 at 10:09

Interesting. You write, the overlay will not displayed. Maybe it is similar with the problem, that the app can even crash (and since the latest version of steam, it will definitely crash on actual wine versions). So you could try the following:

Solution: The compilation way

You simple "patch" the source code of the official open source imm32.dll of wine.

$ git clone git:// ~/wine-git
$ cd ~/wine-git

Optional, but highly recommented:
$ nano Makefile
and change "prefix = ..." to "prefix = /tmp/wine". do the same with "ac_default_prefix = ..." in the file "configure".

Now apply the patch:

$ nano dlls/imm32/imm.c

Search for this line: "BOOL WINAPI ImmProcessKey("... and insert after the "TRACE("... line this new line:

return FALSE;

Please to not forget the ";" char.

Thats all! Now compile:

$ make ./configure
$ make depend
$ make
$ make install

If you are using PlayOnLinux, you can simply add a new wine version:

$ cp -r /tmp/wine ~/.PlayOnLinux/wine/linux-x86/1.7.x-imm-patch

In PlayOnLinux, select the Steam entry and press on the configure button in the menu bar and select the wine version "1.7.x-imm-patch".

You can read it on my blog, too:

Happy wine-playing!

share|improve this answer
Hi, I tried doing this but when I try and compile it doesn't seem to want to. "make /.configure" just says "Nothing to be done for 'configure'. And "make depend" says "*** No rule to make target 'depend'. Stop.". Anything I'm doing wrong? – poncho Aug 22 '15 at 11:49
I followed the official build instructions: . It could be, that the latest source needs other build instructions. But on the other hand, it could be possible, that this the overlay bug is solved in the latest wine release. – Arakis Aug 23 '15 at 21:57
The overlay problem isn't solved for me and I still can't build wine from source so I've given up for now, thanks for the reply though! – poncho Aug 25 '15 at 11:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.