Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have some Bulgarian/Russian songs which have Cyrillic characters in them. Nautilus displays them fine , but in rhythmbox all their id3tag info is displayed as gibberish.

I have set the system language to Russian(UTF-8) .

Downloaded some program named mp3diags with which I tried to convert id3 tags to utf-8 but instead of gibberish the song was displayed with Chinese letters.

I tried to use EasyTag , but could not find out how to mass rename song titles or to convert them to UTF-8.

P.S There are some songs which are displayed right in rhythmbox (i.e I can see the artist name , album , song title just fine - all written in Cyrillic) , does that mean that the problem is in my Songs? If someone has faced similar problem I would be most grateful for some info on solving it.

share|improve this question
    
There is a related bug, which might have a bit to do with this. It has been fixed now bugs.launchpad.net/ubuntu/+source/rhythmbox/+bug/992154 –  Zilvador Jan 9 '13 at 17:05

1 Answer 1

up vote 5 down vote accepted

This is a common problem with Cyrillic id3tags encoded in Windows.

There is a python script, tag2utf, you could try to fix the encoding.

Just place the script into the same folder where the songs are, run it with python ./tag2utf-0.16.py, and follow the prompt.

Reportedly, there is also another tool, mid3iconv. It is part of the python-mutagen package in the repositories.

share|improve this answer
    
Thank you! This worked perfectly. I stumbled on the same script while searching on google , but had no idea how to execute it. Now Rhythmbox recognizes all the songs. –  Lubomir May 19 '12 at 8:23
    
That is an awesome script. Works great! Just have to select 'c' for every prompt. I wish it did that recursively. –  Igor G. Jan 16 '13 at 6:04
1  
@IgorG. Remove 2nd pair from charsets = {'cp1251':'c','koi8-r':'k' } and you are done –  Artem Ice May 18 '13 at 20:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.