Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I uninstalled the official release of php5 for Ubuntu and installed my own from source. Everythings great and it's all installed except even with using the checkinstall command and naming my package "php" I cannot seem to get Ubuntu to register the temrinal php command to my new PHP install.

So I wanna be able to do:

php -v

And for Ubuntu to kow the binary is in say /etc/php5 and it's installed. How would I go about this?


share|improve this question

closed as too localized by Eric Carvalho, Basharat Sialvi, Kevin Bowen, Jorge Castro, user68186 May 27 '13 at 2:45

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

Try using whereis php5 command in terminal –  Srinivas Gowda May 18 '12 at 19:31
That just tells me where php is installed it doesnt allow me to assign the command to a binary that was not installed from Ubuntu repos –  Sammaye May 18 '12 at 19:48
Ahh I thought I'd delete everything listed there and did it again and it worked, thanks mate –  Sammaye May 18 '12 at 20:06
Did you resolve your issue? –  pl1nk Jun 24 '12 at 13:20
Yea, I found out it was because there were conflicts within some of the PHP installation files due to the old ones not being completely removed, doing a whereis allowed me to clear this and once I installed the prog to /usr/bin again php worked by just calling php from terminal. –  Sammaye Jun 24 '12 at 13:31

Browse other questions tagged or ask your own question.