Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been experiencing a few problem with my monitor HP TS-19SV even with the newly released Ubuntu 12.04 (although, this had happened before on Ubuntu 11.10, 11.04, 10.10 and 10.04. Basically, from time to time, when I start my computer and got to the Ubuntu's desktop, I see quite a bit of black lines next to my cursor and when I move the cursor up to the limit of the screen, the desktop fills with those weird lines. Something similar happens when a move the cursor at the bottom of the screen. Obviously, an image will be more helpful than my attempt of description:

Look at that rectangle next to my cursor:

Look at that rectangle next to my cursor

When I reach the bottom of the screen:

enter image description here

When I reach the top of the screen:

enter image description here

Has anyone experienced something similar to this?. How can I solve it?.

Thanks a lot

UPDATE:

After running sudo lshw -C video I get this:

 *-display UNCLAIMED     
       description: VGA compatible controller
       product: P4M890 [S3 UniChrome Pro]
       vendor: VIA Technologies, Inc.
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 01
       width: 32 bits
       clock: 66MHz
       capabilities: pm agp agp-3.0 vga_controller bus_master cap_list
       configuration: latency=64 mingnt=2
       resources: memory:d8000000-dbffffff memory:fd000000-fdffffff memory:fe8f0000-fe8fffff

UPDATE II: The answer given by Luis Alvarado solved this issue. There is still a weird fading effect when I shut down / Log out that happens when there is a process waiting to be closed but for the most part, everything is working great.

share|improve this question
    
@UriHerrera Thanks. According to the DirectX Diagnostic Tool, I have the following information: Name: Standard VGA Graphics Adapter, Chip Type: VIA P4M890, Monitor: Generic PnP Monitor, Main Driver: vga Version: 6.1.7600.16385. I'm not sure if this is the information you need, as this is probably related to the fact that my graphics are recognized automatically in Windows. –  Robert Smith May 19 '12 at 1:30
    
I've had the exact problem before, It happens sometimes when starting or longing in/out, Can you post the output of xrandr just type that in terminal, and your xorg.conf file located /ect/X11/xorg.conf . basically ubuntu was trying to use a refresh rate that is too high to display right. don't mess around with drivers until we can rule this out. –  Mateo May 22 '12 at 0:59
    
@mateo_salta Thanks also for your help. I'm not in the computer with this problem at the moment, however, tomorrow I will add the output of xrandr. I'm running Ubuntu 12.04 so there is no xorg.conf by default. –  Robert Smith May 22 '12 at 3:58
    
did you do an upgrade from 11.10, there sill may be a file, or backups from previous configurations, named like xorg.conf.somethingelse , in the same folder. if the xorg.conf is not there or empty, if not we will probably need to make one. –  Mateo May 22 '12 at 13:15
    
@mateo_salta No, I did a clean install. It seems my problem has been solved as per Luis Alvarado's instructions but thank you very much for your help. –  Robert Smith May 22 '12 at 17:46

1 Answer 1

up vote 6 down vote accepted
+50

Looking at this part of your question: P4M890 [S3 UniChrome Pro] I noticed you had a video card that is in the group of the OpenChrome drivers. There is some good news and bad news. The Bad news is that it has many graphic related issues. you can see several of them (Most for the 3D graphics part) here: https://help.ubuntu.com/community/OpenChrome

The good news are the following:

On the same link provided above: https://help.ubuntu.com/community/OpenChrome you can see that there is a compiling from source workaround that "probably" could work for the 3D part.

There is also some workaround fixed to disable 3D altogether. By editing the xorg.conf: and adding the following:

Section "Module"
        Disable    "dri"
EndSection

(there are a couple of more xorg.conf edits in the link provided)

There is also a ticket system for bugs detected: http://www.openchrome.org/trac/report/1

(Some of the tickets have ideas and comments about how to fix some of the problems)

Lastly, if not downloaded already (It should be downloaded since it is done by default), download the xserver-xorg-video-openchrome package. And tell xorg.conf to use the following driver in the Device Section:

Driver "openchrome"

One final note, some links point to downloading the proprietary VIA driver for this from here: http://linux.via.com.tw/support/downloadFiles.action for what I could see it is very abandonware since the only one I found there was the 9.04 version driver.

Anyway you have several options that might help, others that might help and a little bit more complicated and the last ones which are just to eliminate 3D completely.

If the file xorg.conf is not found, you can created by doing the following:

  1. Boot the system in Recovery Mode. You can do this by pressing ESC or leaving the SHIFT key pressed until the GRUB menu appears. Select Recovery Mode (Should be second option).

  2. After booting go to the terminal as root. There is an option that tells you if you want to log in the terminal.

  3. Type X -configure. The X is in upper case. This will create the file xorg.conf.new in your current home directory.

  4. Test to see if the file is working by doing this X -config xorg.conf.new. If a gui environment appears and looks good then you can do the following step. If not, I suggest editing the xorg file and changing anything you need until it looks good. You can edit with nano: nano xorg.conf.net doing any modifications and save by pressing CTRL+X and pressing Y to save and quit.

  5. Copy the new xorg file: cp xorg.conf.new /etc/X11/xorg.conf

  6. type exit or reboot to test it out.

share|improve this answer
    
Thank you for your thorough answer. Oddly enough, I didn't have installed xserver-xorg-video-openchrome. I installed it but I had to create an xorg.conf file as it doesn't exist in Ubuntu 12.04 by default. Can you tell if creating such file will work or do I need to go through some of these instructions (askubuntu.com/questions/129941/…) which don't work in my case, by the way. –  Robert Smith May 22 '12 at 3:56
    
Will add it to the answer but yes, if you create the file it will be read by default. –  Luis Alvarado May 22 '12 at 5:39
    
Alright. I had a few troubles (Attempting to start the X server fails "Fatal server error: Can't read lock file /tmp/.X0-lock") but a file xorg.conf.new was created nonetheless. I followed your instructions and I haven't had any issues so far, so it looks great for now :-). –  Robert Smith May 22 '12 at 17:43
2  
Test it out for a couple more hours. I recommend a 48 hour test. If everything looks good accept the answer and if you can, add anything else that might help future readers since this is a topic that is almost abandoned for OpenChrome users. –  Luis Alvarado May 22 '12 at 20:01
    
Great. I will do that. –  Robert Smith May 22 '12 at 20:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.