Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just updated to Ubuntu 12.04 from 11.10 but soon after updating I was disappointed to see that

Wireless is disabled by hardware switch.

I can not click the button 'Enable wireless' which is greyed out. Without wireless my computer is useless as I have to connect by wire which is not practical. I have a Acer TravelMate 4500

share|improve this question
4  
You can assume it is a hardware notice: some notebooks have a slider at the left of right of the casing. And some have a keyboard combo (Fn + F3 on my machine). and do not forget BIOS: wifi might be disabled there. –  Rinzwind May 19 '12 at 17:14
    
On an HP Envy laptop if you shutdown with wifi disabled by the hardware switch (Fn F12), then it will be disabled when you boot and network manager will give up trying after 60 seconds, and on each subsequent reboot, whether or not you re-enabled wireless while you were up or did a sudo service network-manager restart. –  hobs Apr 4 '13 at 3:38
add comment

5 Answers

Same happened to me, simply resolved with:

rfkill unblock all

rfkill list all showed some devices on soft block.

share|improve this answer
    
Very useful. Many thanks –  simo Sep 6 '12 at 18:44
4  
This is why Linux fails to hit a bigger audience... stupidity like this. I run dual boot. In Ubuntu I was able to accidentally disable my wireless hardware completely... it wouldn't even reenable in windows -- so I changed something below the OS abstraction. Seriously? I event spent $30 on a USB wireless trying to fix this. Linux, I loath you but love you too. Thank you @Luca for this solution to my problem. Give me your address and I'll send you this Micro USB Wireless device. –  kingdango Dec 15 '12 at 1:30
2  
I had the same problem just after clicking "disable wireless" because a network kept trying to reconnect that required authentication (kept popping up and I was trying to work). Then wireless also stopped working in windows and not until I did rfkill unblock all AND restarted was the Enable Wireless option available again –  mavix Mar 29 '13 at 0:59
add comment

There are two types of radio kill switches: 'hard' (or physical) and 'soft' (software). The rfkill list command will tell you whether either (or both) of these are set for any connected radio devices.

If your wireless card shows "Hard blocked: yes", then a physical switch on your laptop case is turned off. Turn it on.

If your card shows "Soft blocked: yes", then you can turn it back on by running rfkill unblock <ID> where is replaced by the number from the rfkill list command.

There is a bug in network-manager, where if you disabled wifi by right-clicking on the applet and un-checking "Enable Wireless", then the menu option becomes grayed out and can no longer be re-enabled. This persists after rebooting. It looks like NM is soft-blocking the wireless card when you disable it (which is a reasonable thing to do), but then graying out the menu item because it is soft-blocked (which is not a reasonable thing to do).

share|improve this answer
    
Do you have a link to the bug report for this? –  Eliah Kagan Jun 24 '12 at 5:48
add comment

if you just want to reactivate your wifi...

sudo rfkill unblock wifi
share|improve this answer
    
Thanks, I think sudo is important, and seemed to work for me where it didn't without sudo. Thanks :) –  Andrew M Dec 8 '13 at 12:27
add comment

I don't know the Acer Travelmate 4500 but I had a similar problem with a Dell laptop.

Firstly I assume there is no hardware switch ie a physical wireless switch on the side or underneath the laptop?

If not then, interrupt the boot sequence by pressing the F2 key "Set up" (it may be a different key on your machine) and then look for the wireless settings and ensure they are set correctly.

share|improve this answer
    
- It seems that my wireless is set up correctly on my settings but I was not completely sure what I was looking for –  Sahil May 19 '12 at 11:30
    
You have to look for whether "enable wireless at boot/start" is enabled. –  Nirmik May 19 '12 at 17:58
add comment

Try this $ sudo rfkill unblock all

Also hit the key on your keyboard that switches your wifi on and off.

Another method that usually 100% effective is to simply connect your cable wire to your laptop for a few minutes then unplug it. Reboot and your wifi should be working.

Also as mentioned above network manager is buggy.

I like to use WICD because it is a simple and easy to use network manager. Its a very good alternative to network manager in Ubuntu and it seems to always work when Network Manager doesn't. To install it just open up the terminal.

To download and install WICD

sudo apt-get install wicd-gtk 

And now you need to uninstall NetworkManager:

sudo apt-get remove --purge network-manager-gnome network-manager 

Now you can find WICD in your menu Start WICD, find the network you want to use and enter the information needed, password, encryption, etcetera and choose Automatically Connect to this network. You should be good to go!

WICD may also be available in Ubuntu Update Manager so you can look there first but it is important to uninstall Network Manager completely to prevent conflicts!!

share|improve this answer
add comment

protected by Community Jul 17 '12 at 9:16

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.