Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been working on my problem(s) since yesterday morning. I had a bad shut down on my system. Upon reboot Grub seemed fine I was able to mount my encrypted drive, and delivered to lightdm login prompt. After typing my password, screen dropped to verbose for a sec like usual, but instead of taking me to my desktop I was back at my login screen. O.K. I tried various workarounds. First tried ctrl+alt+F1 dropped to console logged in my user, ran startx, output was:

xauth: file /root/.Xauthority does not exist


Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.


Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.

ddxSigGiveUp: Closing log
Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyxinit: giving up
xinit: unable to connect to X server: Resource temporarily unavailable
xinit: server error

Next, I ran startx -- :1.

After that screen just went black....nothing!

Hmmm....reboot now!

I repeated above process. This time I logged in through tty console, stopped lightdm, remembering

Server is already active for display 0

Ctrl+Alt+F6 confirmed lightdm was stopped. I did delete the specified file at /tmp/.XO-lock.

Yes at that point I was able to still browse file system and make changes. It's at this point that I should have started moving files to my external HDD. But I still was not all too worried.

Still in terminal. I decided to reconfigure X altogether using dpkg. That didn't work. I ran sudo dpkg-reconfigure -a and there were no errors. Good. Maybe I should have ran update-initramfs and update-grub just to cover my bases but I did not!

Reboot now!

GRUB is still working. I'm still able to successfully mount encrypted volume sda5_crypt. (The only light I can still see at the end of this tunnel.)

Now after I successfully mount the encrypted drive, I'm dropped to initramfs prompt. Well this might be good, so I type exit and my output looks like:

/init: line 352:can't open /root/dev/console: no such file
[ 432.790729] Kernel panic - not syncing: Attempted to kill init!
[ 432.790790] Pid: 1, comm: init Not tainted 3.2.0-24-generic-pae #37-Ubuntu
[ 432.790851] Call Trace:
[ 432.790884] [<c1592732>] ? printk+0xx2d/0x2f
[ 432.790926] [<c1592600>] panic+0x161
[ 432.790969] [<c105dfe4>] forget_original_parent+0x1e4/0x1f0
[ 432.791024] [<c10eab21>] ? perf_cgroup_attach_task+0x11/0x20
[ 432.791077] [<c10eab30>] ? perf_cgroup_attach_task+0x20/0x20
[ 432.791130] [<c105e004>] exit_notify+0x14/0x140
[ 432.791174] [<c105e7dc>] do_exit+0x1ac/0x390
[ 432.791215] [<c114497d>] ? vfs_write+0xed/0x160
[ 432.791260] [<c105eb18>] do_group_exit+0x38/0xa0
[ 432.791304] [<c105eb98>] sys_exit_group+0x18/0x20
[ 432.791350] [<c15af11f>] sysenter_do_call+0x12/0x28
[ 432.791400] panic occured, switching back to text console

Any help in recovering my broken system would be greatly appreciated.

share|improve this question

closed as too localized by Luis Alvarado Jun 16 '13 at 3:38

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.