Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I always used vgaswitcheroo to turn off my discrete graphic, I did a script to turn off in boot, but now, vgaswitcheroo isn't working anymore, I don't know why... look

forbidden404@forbidden404-Inspiron-N5110:~$ ls -l /sys/kernel/debug/vgaswitcheroo/switch
ls: cannot access /sys/kernel/debug/vgaswitcheroo/switch: Permission denied
forbidden404@forbidden404-Inspiron-N5110:~$ grep -i switcheroo /boot/config-*
/boot/config-3.2.0-20-generic:CONFIG_VGA_SWITCHEROO=y
/boot/config-3.2.0-23-generic:CONFIG_VGA_SWITCHEROO=y
/boot/config-3.2.0-24-generic:CONFIG_VGA_SWITCHEROO=y
forbidden404@forbidden404-Inspiron-N5110:~$ sudo su
[sudo] password for forbidden404: 
root@forbidden404-Inspiron-N5110:/home/forbidden404# echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
bash: /sys/kernel/debug/vgaswitcheroo/switch: No such file or directory
root@forbidden404-Inspiron-N5110:/home/forbidden404# ls -l /sys/kernel/debug/vgaswitcheroo/switch
ls: cannot access /sys/kernel/debug/vgaswitcheroo/switch: No such file or directory

And I'm not using any proprietary driver, k?

share|improve this question

1 Answer 1

Try re=installing ATI CC and with CC you can switch between ATI and INTEL. Here is the link

http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx

Otherwise you can also go for re-installing vgaswitchroo and try remounting the directory

share|improve this answer
    
ATI never worked in my notebook, I already tried six times and it always screwed my Xorg or works so well that I just can use Unity 2D. I tried to remounting the directory and didn't work, I can't find how I can re-install vgaswitcheroo, since this come in Kernel –  Forbidden404 May 18 '12 at 18:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.