Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing ubuntu 12.04 Gedit has gotten much better (faster), and I'm considering using it for LaTeX.

I have installed TeXLive 2011 via their own installation script (Ubuntu repositories only have 2009 version), so I'd like to install gedit-latex-plugin without installing TeXLive from the repositories. This should be possible as far as I can see, as texlive is only recommended by the gedit-latex-plugin package, but I guess that there is some dependency of tex, that is only fulfil-able by texlive, which Synaptic doesn't show me.

Now, I'd like to know the following: Does anyone know of anywhere I can get this plugin without this dependency?

I have tried looking at the plug-ins homepage, but I find it a bit confusing.

share|improve this question
1  
This site works best if you ask one question at the time. I suggest that you move the question about if the plugin is good to another question. –  N.N. May 19 '12 at 6:18

2 Answers 2

up vote 3 down vote accepted

I believe you need to install a dummy package to fool the system into believing the distribution's Tex system is installed, one of the best instructions I have seen to do this is here: http://blogs.ethz.ch/ubuntu/2011/03/14/tex-live-2010-installation/ , it is for Texlive 2010 but just make the modifications to suite your version and platform and it will work.

It essentially means using the equivs package to build the dummy package, for you to install, you still need to install tex-common texinfo and lmodern, perl-tk` is used by the Texlive update system GUI Implementation so if you want to run tlmgr with a Gui you should install it.

share|improve this answer
    
Made it work, but removed a few dependencies from the dummy package compared to the description. I don't have tex-common or other repository tex packages installed. –  beruic Jun 19 '12 at 20:54

You cannot install gedit-latex-plugin without installing the TeX Live packages because gedit-latex-plugin depend on rubber which depend on texlive-latex-base (even though rubber's dependence on TeX Live is questionable). It may be possible to solve it via dpkg, such as via --ignore-depends=gedit-latex-plugin, but I am unfamiliar with it.

share|improve this answer
    
I have tried that, but even though I have changed the settings to NOT treat recommended packages as dependencies, it unmarks the plugin when I unmark anythin texlive. –  beruic May 19 '12 at 16:05
    
@beruic Sorry to dissapoint you, I have updated my answer. –  N.N. May 19 '12 at 16:49
    
Well, at least you helped me find the missing link. I never considered looking at rubber. Thanks :) –  beruic May 19 '12 at 19:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.