Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem both with mounting and with unmounting my USB hard drive. This appeared when I upgraded to 12.04. Since then, when I insert the HD I get a message:

Unable to mount FreeAgent Drive

Error mounting: mount exited with exit code 1: helper failed with: mount: only root can mount /dev/sdf1 on /media/FreeAgent Drive

So I try a

sudo pcmanfm

And open the file manager with the required rights. I then do my business and eject the drive.

The problem is, that when I shut down the computer then, it does not shut down. It remains on, just the window system gets shut down. Then I see a black screen with various undecipherable text going on and the computer is not responsive. I have to shut it down manually.

Another problem is when I turn on the computer. Before the window system is turned on, I get a message which goes approximately something like this:

media/FreeAgent Drive (my disk) is either missing or not yet available. Wait or press S to skip mounting

When I skip and do not mount the disk thereafter, I am able to shut the PC down without the before mentioned shutdown problem.

Please what should I do?

EDIT:

my etc/fstab file:

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc    /proc   proc    nodev,noexec,nosuid     0       0
#Entry for /dev/sda7 : UUID=2fbc1e96-8d74-485e-8077-91e98d2275cb       /       ext4    errors=remount-$
#Entry for /dev/sdf1 : UUID=646CFE7D6CFE48F6   /media/FreeAgent\040Drive       ntfs-3g defaults,nosuid$
#Entry for /dev/sda3 : UUID=308E15138E14D2E8   /media/OS       ntfs-3g defaults,locale=en_US.UTF-8    $
#Entry for /dev/sda2 : UUID=22004B9B004B7537   /media/RECOVERY ntfs-3g defaults,locale=en_US.UTF-8    $
#Entry for /dev/sda8 : UUID=bcb597e7-2400-4ce5-8ee8-c75f5b512b4d       none    swap    sw      0      $
share|improve this question
    
Please paste the contents of /etc/fstab –  izx May 18 '12 at 13:58
    
So I deleted the #Entry for /dev/sdf1 and now everything works as expected. Thank you! –  Martin Drozdik May 21 '12 at 4:53
add comment

1 Answer

up vote 2 down vote accepted

You added a line to your /etc/fstab file to mount the drive at boot time.

Removing that line will fix the problem.

share|improve this answer
    
So I deleted the #Entry for /dev/sdf1 and now everything works as expected. Thank you! –  Martin Drozdik May 21 '12 at 4:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.