Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Ubuntu 12.04 recently on my computer, but there's no sound.

My computer mobo is Intel and it has VGA, DVI and HDMI outputs, all of them onboard. But I installed on it an external PCI-e nvidia video card with another three VGA, DVI and HDMI outputs. My monitor is plugged on nvidia card's DVI port, so both HDMI ports are unused

Here's results of command "aplay -l":

**** Lista de Dispositivos PLAYBACK Hardware ****
placa 0: Intel [HDA Intel], dispositivo 3: HDMI 0 [HDMI 0]
  Dispositivo secundário: 1/1
  Dispositivo secundário #0: subdevice #0
placa 1: NVidia [HDA NVidia], dispositivo 3: HDMI 0 [HDMI 0]
  Dispositivo secundário: 1/1
  Dispositivo secundário #0: subdevice #0
placa 1: NVidia [HDA NVidia], dispositivo 7: HDMI 0 [HDMI 0]
  Dispositivo secundário: 1/1
  Dispositivo secundário #0: subdevice #0
placa 1: NVidia [HDA NVidia], dispositivo 8: HDMI 0 [HDMI 0]
  Dispositivo secundário: 1/1
  Dispositivo secundário #0: subdevice #0
placa 1: NVidia [HDA NVidia], dispositivo 9: HDMI 0 [HDMI 0]
  Dispositivo secundário: 1/1
  Dispositivo secundário #0: subdevice #0

I know that, in theory, HDMI sound is working. But I need analog sound, because my monitor has no HDMI port. Here's results of lspci command:

00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:16.2 IDE interface: Intel Corporation 5 Series/3400 Series Chipset PT IDER Controller (rev 06)
00:16.3 Serial controller: Intel Corporation 5 Series/3400 Series Chipset KT Controller (rev 06)
00:19.0 Ethernet controller: Intel Corporation 82578DC Gigabit Network Connection (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 IDE interface: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA IDE Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
00:1f.5 IDE interface: Intel Corporation 5 Series/3400 Series Chipset 2 port SATA IDE Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 8400 GS] (rev a2)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
3f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
3f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
3f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
3f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
3f:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
3f:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

Anyone had a similar problem?

EDIT: Solved my problem. Analog sound on my soundboard was disabled on bios. After activating, everything worked nice.

share|improve this question
add comment

1 Answer

I have the same card. It worked fine in 11.04 (not sure if it took any fixes), but I was struggling to get it to work after installing 12.04. Found a solution here that worked: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/703464

Open this file:

/etc/modprobe.d/alsa-base.conf

And add this line to the bottom:

options snd-hda-intel model=generic

Then, restart the computer. Hope this helps.

share|improve this answer
    
Did that a few minutes ago. Still no sound in analog port, only HDMI ones. Can you post contents of your /etc/modprobe.d/alsa-base.conf here? I think this is happening to me because my installation isn't totally "clean". I got a new PC w/ similar specs to the older one, and I simply exchanged HDs. But even with this, everything is working fine, except for sound. –  Leonardo Montenegro May 22 '12 at 13:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.