Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Directly to the point. I cut and pasted several .jpg files from a memory card to a partition in Ubuntu, the partition itself is formatted in NTFS actually. Now the odd things is I created a folder containing those images and I can still open the folder and view the images, before I reboot to update. Then I reboot to my Windows 7 (I am dual-booting) and when I open the partition the folder is not there, I don't know if that's normal but then I rebooted to enter Ubuntu and when I mount the partition, the folder turned to a zip file.

I checked the disk usage and calculating from files and folder that is visible and total disk space consumed, I assume that the data is there but how can I recover it? I tried viewing hidden files but to no avail.

share|improve this question
1  
When you say "turned into a zip file" do you mean it has the .zip extension or that the file manager displays it as a zip file? If you right click on the folder you created and go to properties what does the file manager display as the "type" this might shed more light on the problem –  SomKit May 18 '12 at 12:36
    
you say that you found a zip file in ubuntu , dose it contain your photo if was , that happened because of windows hibernate i've faced this problem before. –  eyadof May 18 '12 at 12:39
    
The file manager displays it as zip file, it has no extension actually. The type as displayed by file manager is: Zip archive (application/zip). i can open it but the content is not my photos, just some .xml files and some folder containing another .xml –  Hirdian May 18 '12 at 12:49

1 Answer 1

Hidden files is just for files which start with a period. That does not help.

There are tools to recover images, I think it was PhotoRec that I used successfully in the past.

The less you use that partition, the greater your chances that your files are still there.

Could it be that you enabled volume compression in the NTFS options?

share|improve this answer
    
Will try PhotoRec, thank you. As for the NTFS volume, the compression option is not enabled –  Hirdian May 18 '12 at 12:52
    
Ah, the problem about the lost file is resolved thank you, however i am still curious on what caused this –  Hirdian May 18 '12 at 16:24
    
If it is solved, you can mark this answer as the correct one with the green check mark. –  DaboRoss Jun 9 '13 at 4:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.