Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to Ubuntu 12.04 and am trying to install Persian language support for a friend. I have been googleing for an hour and can't find a tutorial to explain this.

I have added additional language support and added Persian.

What is the next step? How can I type in Persian in LibreWriter please?

Many Thanks

share|improve this question
    
Have you tried to change keyboard layout to Persian in system settings? –  Basharat Sialvi May 18 '12 at 10:48
    
hi, yes I have now added it. But how do I switch keyboard layout? –  Kave May 18 '12 at 10:56
    
Thats it. It works now. :) It was the keyboard layout. You should have added this as answer to tick it off. :) –  Kave May 18 '12 at 10:59
add comment

2 Answers 2

up vote 5 down vote accepted

Click on Gear icon (Session Indicator) in Unity panel and open system settings and select "Keyboard Layout".

enter image description here

Click on little plus button to add a new layout, Search for Persian and add it.

enter image description here

Now you will see a keyboard icon in your Unity panel, Just click on it to switch between layouts.

enter image description here

share|improve this answer
    
Thanks...... :) –  Kave May 18 '12 at 11:06
add comment

Did you install additional language support on OS level, too? If not it's likely that you're missing fonts that comprise farsi characters, and appropriate keyboard layouts. In addition, since farsi requires writing right-to-left, you need to activate CTL (complex text layout) in the language options of LibreOffice. After this is done, you should be able to set farsi as default language for new documents, change the user Interface language, and select farsi as language for the current paragraph from the status bar at the bottom of the LibreOffice screen.

share|improve this answer
    
Hi, I have libreoffice-I10n-fa and myspell-fa already installed. I have setup Libre Writer to Local language persian and CTL is active. But typing still continues in English... –  Kave May 18 '12 at 10:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.