Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a beautiful 27" iMac. I would like to run Ubuntu on it natively, dual-booting with OS X.

I have rEFIt installed, and I can boot into the Ubuntu 10.10 CD, kind of. Here's what happens:

  1. I select the CD from the rEFIt menu
  2. It loads for a while, then flashes up an aubergine screen with a very low-res picture of a human, an arrow and a keyboard
  3. It sits there for a while
  4. It changes to 80x25 console mode
  5. The screen then goes black, as if nothing is displaying to it

All the while, the CD is churning away as if something is reading from it.

What do I do?

share|improve this question
    
I know this is an old post, but you can't use a wireless keyboard (the default for new iMacs). You need to get a plain old wired keyboard. The bluetooth daemon doesn't run until the desktop is loaded, so the loader fails because you don't have a keyboard. –  Patrick James McDougle May 30 '13 at 3:45

3 Answers 3

Try pressing a key at the aubergine screen, then hitting F6 and then Escape to edit boot options. Remove "quiet" (and "splash" in the case of the desktop CD) and see if you get some more information that way.

Which architecture are you using? If amd64, try either i386 or amd64+mac instead.

share|improve this answer
    
Tried all of these. Didn't work. Problem persists in 11.04. Suspect that genix is on the right track. –  jml Jul 7 '11 at 11:27

On imac 27 the output is going to the display port So unless you have a monitor plugged into that You won't see anything this happened to me when Installing ubuntu

share|improve this answer
    
I haven't been able to verify this, since I don't have the right dongle (and it's a bit of a pain borrowing my flatmate's external monitor). –  jml Jul 7 '11 at 11:26

Try downloading the alternative install cd. It will do the same thing but the install will be in console mode. I don't have your hardware but I've gotten around some pesky driver issues that way. Once the system is installed you should be able to boot into it just fine. My experience has been issues with the default video driver or a goofy mass storage system I'm playing with.

share|improve this answer
    
Tried this. Didn't work. Haven't retried with alternative install on 11.04 –  jml Jul 7 '11 at 11:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.