Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 11.10 on Vosto V131 and not able to upgrade to 12.4. I tried several times to do it through 'Update Manager' but failed. I tried from a terminal using: sudo apt-get update && sudo apt-get upgrade then do-release-upgrade and got the following error:


authenticate 'precise.tar.gz' against 'precise.tar.gz.gpg'

exception from gpg: GnuPG exited non-zero, with code 2

Debug information:

gpg: Signature made Fri 20 Apr 2012 01:49:33 PM EDT using DSA key ID 437D05B5

gpg: can't open `/etc/apt/trusted.gpg'

gpg: keydb_search failed: file open error

gpg: Can't check signature: public key not found

Authentication failed

Authenticating the upgrade failed. There may be a problem with the network or with the server.

any idea how to handle it?

share|improve this question

1 Answer 1

Fix permission on the file and it will work

sudo chmod 644 /etc/apt/trusted.gpg
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.