Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Philips 166V3LSB/00 LCD monitor connected to a box with Ubuntu 12.04 LTS.

user@host:~$ lspci
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)

The monitor is supposed to support 1366x768 (16:9) but I cannot get System Settings/Displays to even offer anything but ubiquitous 1024x768 and 800x600. I tried removing ~/.config/monitors.xml and re-logging in but that did not help.

Update (1):

I tried forcing modeline to Xorg.conf (added Modes "1366x768" "1024x768" "640x480"), but as a result:

  • resolution os still the same
  • System Settings/Displays now offers only 1024x768 (it previously offered 800x600 as well)

Here is my current xorg.conf and Xorg.0.log.

Any more ideas?

share|improve this question

you could try forcing a modeline in your xorg.conf file

be careful, if your card doesnt support, you can have some serious issues, make sure you make a back up of that file before you begin to edit it.

check this out for more information:

its possible, that your video driver does not support the resolution and aspect ratio that you desire.

share|improve this answer
Unfortunately even modeline did not help. I have updated OP – Alois Mahdal May 18 '12 at 17:24
this is old but it mentions optimizing your graphics chipset: – supermariolinux May 20 '12 at 1:08
check this out:… – supermariolinux May 20 '12 at 1:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.