Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 12.04, and I've installed Gnome3 on it.

Firefox used to run normally, but one day I used the "snap" feature to snap it to the left and then maximized it again. The websites however refuse to use the rest of the screen and instead use only the left half (actually close to 70%) as shown in the screenshot.

[Screenshot][1] (I can't post the image directly, don't have enough rep.)

I haven't faced this problem with any other application, and any number of application restarts or system restarts (including switching to Unity) haven't helped.

If it helps, I was using the Tree Style Tab extension to display my tabs in a sidebar on the left, but disabling the extension hasn't helped, as the screenshot shows.

How can I get it back to normal?

share|improve this question
    
Does this appear in Unity, too? (Log out, then before logging in again choose "Ubuntu" as session.) –  Jakob May 17 '12 at 19:27
    
Yes, it does. I'll update the question to reflect that. –  vinaykola May 17 '12 at 20:08
    
Try to create a new user profile. Hit (Alt+F2) and run 'firefox -profilemanager' –  Basharat Sialvi May 17 '12 at 21:33
    
... or switch to the Beta channel and try the "magical" new Reset Firefox feature (it'll erase potentially problematic data like extensions, but keep other stuff like bookmarks, history, saved passwords, etc intact). Check it out: blog.mozilla.org/verdi/166/… –  Vicky Chijwani May 18 '12 at 5:34
    
A new profile worked, as well as disabling and re-enabling all my extensions. Still not sure where exactly the problem was. Fixed for me though. –  vinaykola May 20 '12 at 19:18

1 Answer 1

I had a similar problem. I checked the screen resolution and found it to be less then maximum. After maximizing it, in settings -> display, it again took up the whole screen. I did not think that it would be that easy!

share|improve this answer
    
I can't verify your answer, as I can't reproduce the problem again. That could have been the problem; I've been switching resolutions because of switching between my laptop screen and my 24-inch monitor. –  vinaykola May 23 '12 at 16:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.