Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My hardware: Dell xps L502X laptop with integrated intel video card and an GeForce GT 540M (HDMI). My config: Ubuntu 12.04 + nidia drivers 295.53

I didn't manage to use my external display neither in Ubuntu 11.10 with older nvidia drivers.

The problem is that when I want to open nvidia-setings I get

You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

If I run nvidia-xconfig an xorg.conf file is generated and after reboot I get an 640:480 resolution on my laptop and nvidia-setings say the same thing.

Is there a way to use an external display? I don't care If I use nvidia, nuveau or other drivers.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I have the same laptop, your Nvidia card is called "Optimus" and won't run with the normal Nvidia drivers as Nvidia have "no plans to support it in Linux"

However:

There is a guide on this site:

Installing Bumblebee for Nvidia Optimus

Don't be alarmed by the name, it tells you how to set up the Optimus card and how to increase battery life by appx. 60% in my experience.

You will need to remove the Nvidia drivers you have first - Google is your friend for that.

After that you need to splash the cash on a mini DP to VGA adaptor (8-15 British Pounds on Ebay) for your external monitor as there is currently no support for HDMI and Optimus on the Dell L502x at least (others maybe?).

I work using projectors all the time and find this to be a robust and usually stable solution.

This gives me 1366x768 on the laptop and 1080x1920 on my external monitor.

Hope this helps.

Richard.

share|improve this answer
    
my laptop has only a mini DisplayPort (not mini DVI). Mini DP to dvi isn't good? –  telebog May 22 '12 at 10:41
    
Mini DP is connected to intel video card, thats the reason it works hanynowsky.wordpress.com/2012/04/07/… Mini Dp to dvi/hdmi should work also –  telebog May 22 '12 at 10:54
    
Both work just fine in 14.04, with the Nvidia driver from the proprietary drivers settings tab. You can switch from performance (Nvidia) to power-save (Intel) mode. Unfortunately you can connect external screen, but not both screens and have 2 external screens on this setup. –  NoBugs Jul 25 at 3:19

A couple of things:

  • Firstly, you should let xrandr do all the work, and get rid of any 'xorg.conf'.
  • Secondly, you need to understand which ports are connected to which GPU, which you can also use the xrandr command for.

I'm guessing from the fact you weren't able to get it working out of the box that the internal laptop display is only available from the Intel GPU, and the external display port is only available from the Nvidia GPU. If this is the case then your only option is to have both GPUs work together co-operatively (Optimus), to get the job done.

If your laptop isn't muxless, then it's possible you can disable the Intel GPU (using the BIOS display settings), and have the Nvidia GPU drive both the internal display and the external display port, depending on whether it has access to both displays.

If your laptop is muxless, then you no choice but to use Optimus, and you have the following three options available to you:

  1. Bumblebee (max 2 displays)
  2. Nvidia Prime (max 4 displays)
  3. Optimus Prime (max 4 displays)

Each option has it's pros and cons, but I've written an article (Driving Multiple Monitors on an Optimus Laptop) that should be a helpful resource for anybody struggling to understand the differences between these options, and to navigate their way through all the jargon.

share|improve this answer
    
@muru, fair point. I've updated the comment to provide all of the most pertinent information in line. –  domc Nov 14 at 22:24
    
I originally said that Nvidia Prime could only render to two displays, but that was based on an incomplete understanding of Nvidia Prime. I've now updated, but apologies for any confusion. –  domc Nov 25 at 22:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.