Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I started with Ubuntu 11 a few weeks ago. It's on a DELL M4300 with a OCZ SSD. Default setup, except that I've installed the proprietary NVIDIA graphics and BROADCOM wireless drivers. Dual boot with Windows.

If I cold boot into Ubuntu, it is very fast, just like the Windows experience that I'm used to. But SOMETHING happens, and I haven't yet determined what, but the system gets incredibly slow and stays that way.

At first I thought it had to do with Adobe Flash because it seemed to be triggered by sites with Flash. But then I removed Flash and the problem remains.

I thought it was just an overheating problem, but I've now upgraded to 12.04 which supposedly fixes the overheating problems I've read about. Perhaps the heat situation was brought on by Flash in my early cases? So I installed Jupiter for CPU management, but the thermometer reports a familiar Windows-side temperature of 53 degrees Celsius. Switching Jupiter to lower performance doesn't help.

When I check the System Monitor application, sorting by CPU usage, there are no obvious problem processes. However, in the graphs tab, both CPU cores are pegged at 100%!

I notice that the slowness seems to be similar to the extremely bad performance I got prior to installing the NVIDIA drivers. I'm not sure if that helps.

This is the strangest part to me - although the temperature seems OK, even after rebooting, the system remains slow - starting with GRUB2 which is very noticeably delayed, all the way through to either Ubuntu or Windows! That's right, even the Windows side suffers effects and takes several minutes to complete booting whereas normally (with my SSD) it's ready to use in 15 seconds. The only way to fix it is to shutdown and let the parts cool down. Or maybe it just needs to completely power off and boot rather than a soft reboot, temperature has nothing to do with it? - is that possible?

But know that I have never had this problem in Windows, even if Windows gets very hot (135 F) a reboot would be enough time for it to recover. For this reason, I don't think it's a heat thing, but I can't imagine what else could be surviving the reboot.

I'm entirely updated - there are no pending updates. I have the Post-Release updates of NVIDIA too, btw.

If this sounds CLOSE to something you know about, but one of the details doesn't line up exactly, it might be a mistake in my perception. Are there tests you can suggest to rule something out?

Thanks!

processor   : 0
vendor_id   : GenuineIntel
cpu family  : 6
model       : 23
model name  : Intel(R) Core(TM)2 Duo CPU     T9500  @ 2.60GHz
stepping    : 6
microcode   : 0x60c
cpu MHz     : 800.000
cache size  : 6144 KB
physical id : 0
siblings    : 2
core id     : 0
cpu cores   : 2
apicid      : 0
initial apicid  : 0
fpu     : yes
fpu_exception   : yes
cpuid level : 10
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 lahf_lm ida dts tpr_shadow vnmi flexpriority
bogomips    : 5187.00
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor   : 1
vendor_id   : GenuineIntel
cpu family  : 6
model       : 23
model name  : Intel(R) Core(TM)2 Duo CPU     T9500  @ 2.60GHz
stepping    : 6
microcode   : 0x60c
cpu MHz     : 800.000
cache size  : 6144 KB
physical id : 0
siblings    : 2
core id     : 1
cpu cores   : 2
apicid      : 1
initial apicid  : 1
fpu     : yes
fpu_exception   : yes
cpuid level : 10
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 lahf_lm ida dts tpr_shadow vnmi flexpriority
bogomips    : 5186.94
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

(Redundant figures removed. You can view them in the edits if they are still relevant)

ps:

%CPU   PID USER     COMMAND
 9.4  2399 jason    gnome-terminal
 6.2  2408 jason    bash
17.3  1117 root     /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch -background none
13.7  1667 jason    compiz
 1.3  1960 jason    /usr/lib/unity/unity-panel-service
 1.3  1697 jason    python /usr/bin/jupiter
 0.9  1964 jason    /usr/lib/indicator-appmenu/hud-service
 0.6  1689 jason    nautilus -n
 0.4  1458 jason    //bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session

I should highlight specifically that GRUB2 can also be very slow. I don't know the relationship of which scenarios GRUB2 is also slow, but WHEN it is slow, it is slow both before the menu appears and after the selection is made - although for the diagnosis of GRUB2 it is harder for me to tell what the normal speeds should be. With SSD, I would expect that GRUB2 could load instantly, and that the GRUB2 purple would disappear instantly after the selection. The only delay to be expected is the change in graphics modes (though I couldn't guess why that ever requires any noticeable time)

share|improve this question
2  
if both windows and Ubuntu suffers, I'd say it's a hardware problem. –  Alvar May 17 '12 at 18:25
    
It's not a hardware problem if I'm able to use windows and reboot windows without issues - it's only when having used Ubuntu that the problem occurs. –  uosɐſ May 17 '12 at 18:27
    
What process causes CPU 100%? –  jasmines May 21 '12 at 9:46
2  
@uosɐſ, can you please post the output of the following: ps -eo pcpu,pid,user,args | sort -r -k1 | head -10 –  Andrejs Cainikovs May 21 '12 at 15:53
1  
Not to restate the obvious but... try checking your fan. I had incredibly similar symptoms to this once and what it turned out to be that my fan was dead. This problem was compounded by the fact that NVIDIA provided DELL with a bunch of faulty GPUs that ran too hot. When I first booted everything went fine, but as the computer heated up everything slowed down to a crawl (including things like system monitor which should be light loads) and then it ultimately powered off. Could be that Windows just takes so long to reboot the computer has time to cool down and Ubuntu just boots too fast! ;P –  adempewolff May 22 '12 at 15:02
show 5 more comments

2 Answers 2

Looking at your logs and screenshots, my first thought went to a heat issue. But you say that your CPU - Intel Core2 Duo T9500 @ 2.60GHz - doesn't go over 60°C and this seems to be reasonable given the very low TDP (35W) of your processor.

I have a Intel Core2 Quad Q6600 @ 2.40GHz with a 105W TDP running Gentoo. When I update the system in summer (Gentoo downloads source packages and compile them directly on the target machine) and the heatsink is not so clean, my CPU goes up to 80°C, but the system doesn't slow down. And this is the correct behavior, because mid-range Intel CPUs works normally even at these temperatures (and they have very good built-in thermal protections that shuts down the CPU before it can take damage).

vendor_id   : GenuineIntel
cpu family  : 6
model       : 15
model name  : Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz
stepping    : 11
cpu MHz     : 1596.000
cache size  : 4096 KB

This is just to say that your CPU can tolerate much more than 60°C, so if its frequency goes down, this shouldn't be called a "heat problem" but, at worse, a misconfiguration problem.

The other thing I noticed is that your /proc/cpuinfo says that your current CPU frequency is 800MHz but your system monitor (you should re-insert the picture, it's important because it gives the timeline of CPU usage) shows a very high CPU usage for a long period of time. So why the frequency is still so low?

IMHO, you have a problem with the ACPI governor. Try a cpufreq-info and see if all the processor frequencies are listed and what governor is in use.

analisi della CPU 0:
  modulo acpi-cpufreq
  CPU che operano alla stessa frequenza hardware: 0 1 2 3
  CPU che è necessario siano coordinate dal software: 0
  latenza massima durante la transizione: 10.0 us.
  limiti hardware: 1.60 GHz - 2.39 GHz
  frequenze disponibili: 2.39 GHz, 1.60 GHz
  gestori disponibili: powersave, ondemand, performance
  gestore attuale: la frequenza deve mantenersi tra 1.60 GHz e 2.39 GHz.
                   Il gestore "ondemand" può decidere quale velocità usare
                  in questo intervallo.
  la frequenza attuale della CPU è 1.60 GHz.

Wait, googling a little deeper, I found this bug (you'll have to click on "Show footer") that shows up exactly on the same DELL model. The problem should be that the module acpi_cpufreq isn't loaded at boot, so your CPU get stuck @800MHz. This would also explain why rebooting on Windows restores the "normal" CPU speed: it's because Windows is using the frequency scaling properly while Ubuntu is not.

Try a sudo modprobe acpi_cpufreq and then a lsmod | grep acpi_cpufreq to see if the module loaded properly. If you can't see it in the list of loaded modules, then it means that there have been problems. Type dmesg | tail to see why the module doesn't insert.

If the module inserts without errors (and the CPU frequency start scaling up properly - check it with several cpufreq-info while launching some programs) but at the next boot you see the problem again, you'll have to find a way to load the module at boot. In the above thread, it seems that installing hal solves this issue. Try with:

sudo aptitude install hal

Or you can just try to add it in /etc/modules. Good luck!

share|improve this answer
1  
I'll give you the points based on the detailed answer - although I don't have time to verify before the Bounty deadline. I'll come back with results. Thanks! –  uosɐſ May 27 '12 at 14:34
    
Thank you! Let me know if the problem if solved, otherwise I'll try to provide further assistance. –  Avio May 27 '12 at 14:35
    
I honestly can't say if any of this fixed the problem but I did go through the steps, finally installing hal and the problem seems gone. It also could be that one of the updates fixed it separately. But it's working now. Thanks for your help. –  uosɐſ Jun 14 '12 at 13:00
add comment

Have you checked your temperatures at stressing the cpu? I get only that 136F at idling, or medium usage. Actually 136F looks too low for me. Im sure about your temps are way mutch higher when your cores at 100% load at 2600mhz. It looks like your cpu has already downclocked itself to 800mhz according your cpuinfo, to prevent itself getting the skyrocketing 100°C (212F) temperatures! The designation limit is actually 105°C, according to intel:

missing link, try hitting t9500 into google

You can try undervolting your cpu. I have the same series dell latitude notebook also with an nvidia graphics, with the same chipset. Its a dell D630 and this have some overheating problems too, since my T9500 can get more than 90°C (194F) with the factory settings. Then it always switches back to the minimal 800mhz state, from 2600, when it gets a constant load. After successful undervolting it stays around 70-80°C(160F) at heavy dualcore duties, and with prevention of the performance loss. (2600->800mhz anymore) Not mention the positive effect on battery times, and the cpu health, due to lower temps.

If you dont know what undervolting stands for, you can looking into this. Basically running your CPU at lower voltages than the default, but with same speed:

http://forum.notebookreview.com/hardware-components-aftermarket-upgrades/235824-undervolting-guide.html

To get undervolting in linux explore this forum. They got a PPA, and howtos, technically everything to get undervolting to work in a linus (ubuntu) system.

missing link, try hitting phc forums into google

You can add their PPA to your system, then install the 'patched' kernel module. By doing this for example there is a good howto:

http://openmindedbrain.info/09/05/2010/undervolting-in-ubuntu-10-04-lucid-lts/

After that you can try my settings by entering into a terminal, and check does your T9500 can run stable. The success with those settings are not guaranteed, because all cpu-s are different, then different models have different voltage tolerances.

The default T9500 settings by intel, you can query this by typing this into a terminal:

cat /sys/devices/system/cpu/cpu0/cpufreq/phc_default_controls
14:40 13:34 10:30 8:27 6:23 136:19

Mine runs stable at, to make sure both cores have same voltages:

echo "14:28 13:22 10:19 8:19 6:19 136:19" > /sys/devices/system/cpu/cpu0/cpufreq/phc_controls
echo "14:28 13:22 10:19 8:19 6:19 136:19" > /sys/devices/system/cpu/cpu1/cpufreq/phc_controls

As far my research into this field every entry is a vid:fid state. Your OS chooses from those dependng on cpu load, or you can manually select one for example with a Gnome 2 applet.

Vid = voltage identification

19 roughly 0.9375V and 40 is 1.2V Another notification about those vids, you cant go below 19, even you can set it, since intel has been locked the smallest voltage. Only you can workaround this by connecting the processor pins to cheat the motherboard.

fid = frequency identification. Its a multiplier of the base fsb. T9500 200mhz at quad data rate. so:

14 = 14*200= 2800mhz only possible when pne core is inactive. It stands Intel dynamic acceleration. Its the predecessor of the i5, i7's turbo boost. It doesn't give much extra, you can disable this in your dell bios. Actually it doesn't get this state for long, since you OS always executing some code on both cores.

13 = 13*200= 2600 the maximum possible state at both cores active

10 = 10*200= 2000

8 = 8*200= 1600

6 = 6*200= 1200

136 = 8*100= 800mhz! Its a frequency halved state. the 7th bit at this vid stand for the reduced fsb frequency. so 128+8=136.

If your system hangs, or crashes, then reboots at this voltages, you can try higher vids first! After getting the correct voltages for your needs, you can set up a startup script, to make sure your settings are always applied.

For windows, the undervolting is much more easier, since you can simply download a free undervolting software, and then go play around with it. For example, RightMark CPU Clock Utility (RMClock) is a decent one:

missing link

Good luck!

share|improve this answer
1  
If there was originally a link at "missing link, try hitting t9500 into google" (but you edited this quickly after posting, removing it), then you might want to include a link to that page's archive at archive.org, if there is one. –  Eliah Kagan Jun 22 '12 at 22:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.