Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Just installed Ubuntu 12.04 64-bit on my ACER 5742 laptop. The performance is really slow.

While browsing pictures in Google, occasionally my system just freezes for about 5 seconds. Also, installing applications takes a lot of time. For example, installing "Skype" took me about 30 min or so.

In October, I installed earlier version of Ubuntu, and that version did not display any of these symptoms, so my laptop isn't to blame. And, my laptop's specs aren't that bad:

Model: Acer 5742g
Processor: Intel Pentium P6200 2.13GHz (duo-core)
Graphics Card: AMD Radeon HD6370M, 512 MB
RAM/Memory: 6GB 1066Mhz
Hard drive:: 500GB (5200 RPM)

I tried both a USB HDD and my 5200 RPM 500GB HDD.

I installed all the drivers that were displayed in Additional Drivers. But still, there is no improvement in performance.

Is it better to just install earlier version of Ubuntu or what?

share|improve this question

marked as duplicate by Eliah Kagan, Kevin Bowen, Andrea Corbellini, jokerdino Aug 26 '13 at 13:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Had same problem but I have change Unity for 3d to 2d and it looks to be work fine, lets hope it stays this way, else i will go back to version 11.10. –  user64243 May 17 '12 at 19:42

3 Answers 3

up vote 1 down vote accepted

unity 3d (default ubuntu interface) probally is too heavy for you, try a diffrent Desktop Enviorment and Window Manager, like LXDE, or XFCE

you can get a lxde enviorment with your current install by installing the lubuntu-desktop package

sudo apt-get install lubuntu-desktop

or for xfce- xubuntu-desktop

sudo apt-get install xubuntu-desktop

you could also try gnome-panel package for a more traditional pre 11.04 like interface (like gnome2)

share|improve this answer
    
Why don't you try using Unity 2d, which is like unity 3d with a little less of the fancy effects. –  Dragon5689 Jun 22 '12 at 17:37

Another alternative: Try to change unity 3d to 2d by clicking on the "unitysymbol" at the loginscreen (next to your login name).

Malte

share|improve this answer

You installed the drivers: That's the problem. AMD has had bad driver support for Linux and Ubuntu since the beginning of the ATi Radeon chipset back in 2000. Common complaints after installing AMD/ATi graphical drivers are: slow performance, slow and/or delayed compiz (visual effects) actions, and just bad system performance in general. Uninstall the drivers immediately with the Additional Drivers tool and reboot. You can install CompizConfig Settings Manager in the Ubuntu Software Center to handle any advanced graphical changes or alterations you want to make to your system.

share|improve this answer

protected by Community Jul 30 '12 at 12:14

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.