Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two configurations An older laptop (Lenovo 3000 C200, network controller Broadcom BCM4311) with Ubuntu 10.04 and a newer laptop (Lenovo B570e, NW controller Broadcom BCM4313) with the 12.04 Ubuntu.

In the first configuration I can see all my neighbours' wireless networks + my own wireless, but with the second config I cannot see my network (I can see neighbours' networks). Any ideas?

I did not change wireless driver settings on the newer configuration. I think I did it on the older configuration because it was offered when I booted for the first time.

I can connect to this network with both Nokia and HTC phones, so I would say the problem should not be on the router side.

share|improve this question
    
Can you connect to the WLAN if you create the connection manually? What encryption does it use? Hidden SSID? –  Bobby May 17 '12 at 16:40
    
I've tried connect to hidden wireless NW and create the connection manually but it never chooses it. It uses WPA&WPA2 as security –  nem0 May 17 '12 at 16:46
    
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information. –  Jorge Castro May 17 '12 at 17:06
    
additional information added –  nem0 May 17 '12 at 17:23
    
where did you add the additional information? I do not see it? –  irrational John May 19 '12 at 22:05
show 1 more comment

2 Answers

Same problem here, on a fresh (not upgraded) 12.04 system. If this is of any relevance, the computer is a "DELL Latitude E4300" and the Wifi card is a "Broadcom Corporation BCM4322".

The problem was solved by changing the router channel from 12 to 3. (Intriguingly channel 7, which was my first pick, did not seem to work either...)

share|improve this answer
add comment

I had the same problem with my Lenovo S10-3t. Installed 12.04 next to 10.1. It never could see my own wireless network, but it could see and connect to many other ones. I always had to reboot into 10.1 to use wireless. Then I switched the radio channel of the router (Apple Time Capsule) from 12 to 10 and voila my network showed up after waiting for maybe 30 seconds! So it is definitely a problem of 12.04.

share|improve this answer
    
According to en.wikipedia.org/wiki/List_of_WLAN_channels, there are regulatory restrictions on the use of channel 12 in the United States. If you are in the US, perhaps the difference is that the driver in 12.04 is observing those restrictions differently? –  James Henstridge Aug 6 '12 at 5:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.