Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running a 64-bit version of Kubuntu 12.04. When trying to run a 32-bit .bin file I am getting the following error:

$ ./jdevstudio11121install.bin
./jdevstudio11121install.bin: No such file or directory

However when I run a file command I receive the following:

$ file jdevstudio11121install.bin 
ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.2.5, stripped

How do I run this file? Is it possible to run 32-bit executable on a 64-bit OS. Please help me.

share|improve this question
Possible duplicate of…. The bottom line is run sudo apt-get install ia32-libs -y first and then try again. – izx May 17 '12 at 15:33
@izx This question is substantially more specific than that one. It seems to me that this shouldn't be considered a duplicate of it, even if the answers are essentially the same. – Eliah Kagan May 17 '12 at 15:48
up vote 4 down vote accepted

Type this in the Terminal:

sudo apt-get install ia32-libs

This will install most needed 32 bit libraries and hopefully you will be able to run the file.

Or if you prefer, you can install the ia32-libs package in the Software Center.

share|improve this answer
thanks a lot, This solution worked – Sameer May 19 '12 at 8:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.