Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As there's a critical bug in PiTiVi 0.15.1 (version released in Software Center) and I need to finish a project, I tried to install the latest version, 0.15.2. I tried to add the PPA and to compile it (I found the instructions at the PiTiVi website), but I had no luck. What should I do?

I'm using Ubuntu 12.04 in an iMac 21'5'' Late 2009.

share|improve this question
    
If its in a PPA, it shouldn't need compiling. If you are compiling the source from the website, please post errors, warnings, etc. –  izx May 17 '12 at 15:11
    
No, I tried to install the PPA 'and' to compile the source. –  espectalll123 May 17 '12 at 15:16

3 Answers 3

up vote 3 down vote accepted

The PPA does not include any packages for Precise (12.04), and contains no packages for the version you want either (0.15.2), so it's useless. You can remove it from Software Center or using apt-add-repository.

0.15.2 compiled just fine for me on Precise 64-bit, with the following. Open a terminal, and run the following to install PiTiVi 0.15.2 on your system

sudo apt-get build-dep pitivi -y
sudo wget -O- http://ftp.gnome.org/pub/GNOME/sources/pitivi/0.15/pitivi-0.15.2.tar.xz | tar -xJ
cd pitivi-0.15.2
./configure && make
sudo make install
share|improve this answer
    
It works, thanks! :) –  espectalll123 May 17 '12 at 18:28
  1. Try sudo apt-get update to update your package list.
  2. Then sudo apt-get autoclean to cleanup any partial packages.
  3. Then sudo apt-get clean to clean up the apt cache.
  4. Then sudo apt-get autoremove to cleanup any unneeded dependencies
  5. Then run sudo apt-get install -f
  6. Then run sudo apt-get update

Now go to the Ubuntu Software Center and remove the PiTiVi ppa which is noted as ppa:gstreamer-developers

Now install the PiTiVi by running the following commands one at a time:

  1. sudo add-apt-repository ppa:gstreamer-developers/ppa && sudo apt-get update
  2. sudo apt-get install pitivi

The whole process should remove all the previously installed broken packages and do a fresh install.

share|improve this answer
    
The PPA doesn't contain packages for Precise and in any case, contains no packages for the version the OP wants (0.15.2). –  izx May 17 '12 at 15:37

what method i will use to remove pitivi if the installation methos is

sudo apt-get build-dep pitivi -y
sudo wget -O- http://ftp.gnome.org/pub/GNOME/sources/pitivi/0.15/pitivi-0.15.2.tar.xz | tar -xJ
cd pitivi-0.15.2
./configure && make
sudo make install
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.