Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The 'enable wireless' button on the top right is greyed out and I am unable to click it and my wireless won't work anymore. What can I do to fix this?

share|improve this question
    
You did try the hardware switch? –  Bobby May 17 '12 at 16:38
    
I'm having the same problem. It was enabled, I clicked to disable it (because that causes it to refresh the network list) and it won't let me enable it anymore. –  G1i1ch Sep 25 '12 at 2:26
add comment

2 Answers

You can try that:

  1. turn on wireless switch
  2. in a terminal windows execute the below command sudo rfkill unblock wifi
  3. reboot
  4. in a terminal windows execute the below command sudo ifconfig wlan0 up
  5. enable wireless in NetworkManager

Worked for me!

share|improve this answer
1  
Great suggestions, especially the wireless switch. I always forget that it exists. –  Eric Wilson Feb 1 at 13:17
add comment

if your hardware switch is on or if you do not have a hardware switch in the first place,

during boot-up go to the BIOS menu and check whether the Enable Wireless at startup is Enabled.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.