Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed the kubuntu-desktop package in Ubuntu 12.04 LTS, but the problem is KDE responses very slowly. If I click on an application's icon to run it, it appears after 10 seconds and sometimes does not appear at all. It hangs all the time. The cursor is almost impossible to follow because of the lag.

I have read on the Internet that Unity uses more memory and CPU than KDE. But on my PC Unity runs smoothly and KDE does not.

So what should I do to make KDE as fast, responsive and smooth as Unity?

My specifications are as follows:
RAM: 1.5 GB (DDR2)
Processor: 3 GHz Dual Core
Graphics Card: Intel HD graphics with 256 MB memory.

share|improve this question
    
You have a very low amount of RAM, I recommend to not go below 4 GB of RAM on any Ubuntu machine. –  Alvar Apr 18 '13 at 9:21
add comment

5 Answers 5

Install kubuntu-low-fat-settings and it will make a big difference. You will loose desktop effects and other non-essential services will be disabled, this is a fair trade-off for less powerful computers.

share|improve this answer
add comment

The package kubuntu-low-fat-settings is very good start, indeed.

If you want some additional manual tweak and fix on slow startup or Youtube slowness, try this (some of them are performed by the above package, others not):

  1. Install KDE backports PPA. The latest releases fixes a lot of memory leaks and 4.10 (and above) is really fast:

    sudo apt-add-repository ppa:kubuntu-ppa/backports
    sudo apt-get update
    sudo apt-get upgrade
    
  2. Disable Nepomuk file indexing: Go to System Settings > Desktop Search. Uncheck "Enable Nepomuk Semantic Desktop".

  3. Uninstall virtuoso-nepomuk, zeitgeist and gnome-keyring packages:

    sudo apt-get purge virtuoso-nepomuk virtuoso-minimal gnome-keyring zeitgeist zeitgeist-core zeitgeist-datahub
    
  4. Disable Desktop Effects, or at least, disable a lot of them, and in case you still use some, make them faster: System Settings > Desktop Effects, under General tab, select for Animation Speed: "Very Fast" or "Instant".

  5. Disable some KDE services: On System Settings > Startup and Shutdown, select "Service Manager", then on "Startup Services" uncheck and stop:

    • Akonadi (if exists, in some desktops it's disabled by default)
    • Application menus daemon
    • DNS-SD Service Discovery Monitor
    • K Remote Control Daemon
    • Nepomuk Search Module
    • Remote URL Change Notifier
    • Write Daemon
  6. Open Krunner (Alt+F2), click on Settings and uncheck all options you don't need (if you don't use krunner at all, uncheck all).

  7. This last one is always valid, for fasting KDE desktops or not: if you want to watch Youtube fullscreen videos, go to System Settings > Desktop Effect, select Advanced tab and check "Suspend desktop effect for fullscreen windows".

  8. Fix Kmix autostart (will improve startup, but need to be repeated every new release while this is not fixed):

    sudo mv /etc/xdg/autostart/pulseaudio-kde.desktop /usr/share/autostart/
    
share|improve this answer
add comment

Don't know if this is an answer or not but the part of the problem maybe the effects that you have enabled? I have noticed on some of my older computers w/ a less powerful graphics card the performance of KDE is very slow. In the Display portion of Systems Settings you can disable the effects and slowly re-enable them until you get to an effect that slows things down too much

share|improve this answer
    
If you include the details about how to disable some system effects, it will be much better –  Anwar Shah Jun 22 '12 at 13:31
add comment

In KDE, press Ctrl+Esc and the running processes monitor should pop-up. See if there's anything in there using too much CPU or RAM. If there is, edit your question to say the name of the application. It could also be an issue with the graphics card driver.

Bottom line, right now the question is too vague, it could be a number of things and more details are needed.

share|improve this answer
add comment

I agree with the first two but a hint of caution when it comes to uninstalling anything using apt-get: be careful when uninstalling software, if it has dependent software, you just might end up uninstalling them also, so make sure you don't use the --yes flag. Usually if you see a screen full of items to be uninstalled when you only specified 2 or 3 things, or something in that ballpark, you may want to go another route. And also, remember to not mix package managers too much because they sometimes do not play nice with each other (I myself have had problems, especially with the GUI based ones, in the past)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.