Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a problem with suspend to disk in ubuntu 12.04 (it worked perfectly in 11.10). I've installed the pm-utils package, but whenever I issue:

sudo pm-hibernate

it appears the screen that notifies me that the s2disk image is being created (and it is), the system powers down, and then it powers up again, taking me back to where I was...

What can I do to prevent the system from rebooting?

I've tried to modify many options in the bios (S1, S3, no reboot after failure etc)


share|improve this question
I'm kind of confused about the sentence "the system powers down, and then it powers up again, taking me back to where I was". It sounds like (to me) the process works if it took you back to where you were before the hibernate. Read this article to understand the hibernation process: – ruffEdgz May 17 '12 at 13:53
Omg, I meant that the hibernation works, but instead of shutting down, it reboots.... – gianni May 19 '12 at 20:29
I think he means the machine hibernates and power cycles right away, not staying powered off. – Bruno May 19 '12 at 23:59
I understand that he doesn't want the system to restart immediately, without interaction, like hitting blank or moving the mouse. The system goes down and straight up again, instead of waiting to wake up. – user unknown May 20 '12 at 0:06
@gianni when poking around a bit more with pm-hibernate, I noticed it happened to me as well (Did the command from above, looked like it went right into hibernation, started right back up). Poked around the launchpad,net site and didn't see anything yet but will also if I can gather more information as to why its happening this way. – ruffEdgz May 20 '12 at 2:11
up vote 3 down vote accepted

Ok, I solved with:

sudo dpkg-reconfigure uswsusp


  • reboot
  • platform
  • shutdown (choose this)

I also added (not sure if it is necessary, anyway it solved the watchdog problem): "blacklist mei" to /etc/modprobe.d/blacklist.conf

Updating the bios, removing all usb devices and hubs, didn't help. Now I have the problem that I doesn't lock the screen after resume....

share|improve this answer
awesome that you solved it. sorry for the confusion on my part. just wanted to make sure everyone (including myself) understood the problem better. – ruffEdgz May 20 '12 at 15:27

I still have this problem with hibernation on my Dell XPS 13 with 12.04 installed.

Even after setting the dpkg command to shutdown as above, on giving the "s2disk" command, my machine saves the snapshot to disk and then comes back to the grub screen. Pressing the hardware switch switches off the machine immediately. The resume works correctly the next time it is switched on.

This is a pain, but it's better than not being able to hibernate at all...(which was the case until a few days back!)

share|improve this answer
Did anyone file this as a bug-report? if not see this – blade19899 Sep 26 '12 at 14:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.