Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Trash bin is not opening. It just shows the "loading" mouse cursor forever. Any idea what can be wrong?

--update (after the answer) After emptying the trash solved also a problem that used to occur when I remove the pendrive, saying that "computer:/// could not be localized" or something like this..

share|improve this question
add comment

3 Answers 3

up vote 2 down vote accepted

Three possibilities come to mind, I'll start with the easier first:

  1. There is a huge number of files in the trash which is blowing some limitation in nautilus or memory.
  2. There is a file in the trash that is causing its respective thumbnail generator to hang
  3. There is a hard error on your disk which is being used by something in the trash

There are multiple approaches to clearing the problem:

  • install package trash-cli which gives you command line programs such as list-trash and empty-trash, these are most likely "safest" in terms of keeping your trash can in proper form.
  • the trash-can is just a couple of directories under $HOME/.local/share/Trash which can be inspected and manipulated with ls and rm from the command line
  • look at /var/log/kern.log and /var/log/syslog for complaints about hard errors on your harddrive.
share|improve this answer
    
"There is a huge number of files in the trash" was a good point. Trying to empty it openned thousands of windows (why? I don't know), and after killing all it is back to normal (looks like). –  Tom Brito Nov 18 '10 at 18:07
add comment

Honestly, no idea.

You might have more success by loading it through a terminal. Most applications are quite vocal about their crashes and failures but nautilus is comparatively silent. Perhaps running it like this killall nautilus && nautilus trash:/// might show you the problem.

You can forcibly delete everything in trash with this (but remember it will delete everything in there):

rm -rf ~/.local/share/Trash/*

If you want to rescue something from the trash, I suggest you browse it and pluck out what you need. You can do this from the terminal and you should also be able to do it via nautilus.

If you find the precise problem, or it persists, make sure you file a bug (ubuntu-bug nautilus)

share|improve this answer
    
+1 for the kill command line –  Tom Brito Nov 18 '10 at 18:09
add comment

I had the same problem and it solved deleting the nautilus hidden directory at user's home. Before deleting, you can rename it to see if the problem solve

cd
mv .nautilus/ .nautilusx
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.